FreePBX | Register | Issues | Wiki | Portal | Support

Google Voice no "ringback" when calling out?


(Bill Jackson) #1

I recently upgraded my PBX system to FreePBX 14 and have been having an issue with dialing numbers since.

When I dial out, I get no indication that the connection is being made until the person on the other end answers the phone. The usual “ringing” that you hear is not there. I poked around and found that it appears that the SIP 180 “ringing” response is not coming back. What I see in the SIP traffic is a 102 invite, a 100 trying, another 100 trying and then the call is connected.

has anyone else seen this issue? I’m using an updated Google Voice/Motif module that solves an issue of not creating the outbound routes and trunks (13.0.4 versus 13.0.2 that is the released version)

All of this worked perfectly fine when I was running FreePBX 13.

Suggestions?


(Bill Jackson) #2

To add some more to this, I dug out one of my old MicroSD cards and restored a full backup from an old configuration (Motif 2.11.17 and FreePBX 2.11.0.43, yea I know that’s really old but it’s the only full backup I had)

Once I adjusted for the changed Ip addresses for my new network in a new state, google voice works as expected. The SIP traffic includes a 180 Ringing acknowledgement from Google voice.

Something weird is happening In this verison of Motif


(Bill Jackson) #3

It appears that this is a bug in “core”, a new version has been released on the “edge” track that solves it. you need core v14.0.5.16 or greater


#4

@wmjackson Can you describe where/how you investigated these responses?

I’m having a similar or same problem with a new install of 13 and I’d like to see if I’m getting the 180 response or not. I typically get one maybe two ringback tones then silence till answered.

My Motif version is 12.0.4.2 (I think - checked in Admin->Module Adminstration under “Connectivity”)

Thanks


(Itzik) #5

I think this is wrong.

Please run
fwconsole ma list | grep motif
If you do have 12.x try updating


(Bill Jackson) #6

You have to have CORE 14.0.5.16 or greater, that’s where the fix for this resides. You will have to delete and recreate all of your Google Voice accounts for it to work properly.

How I found this was using TCPDUMP on my Raspberry Pi (that is running FreePBX), i watched the traffic on the port for my phone to see what was going on. I then stuck an old MicroSD card in the Pi, booted it to an older FreePBX and did the same thing. That had the “ringing” and the newer version didn’t.

I think the command from the Linux command line is tcpdump -vvv port 5060 (or in my case it was Port 5160 since I’m not running PJSIP since it doesn’t seem to like my Cisco 79xx series phones too much.


#7

root@pbx:~ $ fwconsole ma list |grep motif
| motif | 12.0.4.2 | Enabled | GPLv3+ |
WARNING: Always run Incredible PBX behind a secure hardware-based >firewall.
root@pbx:~ $

Looks like 12.0.4.2 is what it is.

How would I go about updating this? (sorry, beyond new to FreePBX…)

Thx.


(Itzik) #8

Are all modules updated?

fwconsole ma upgradeall


#9

You’re saying the fix is in CORE 14.0.5.16 but do we know when the bug was introduced? I.e. did it even exist in 13 (which I’m on)?

I’m running in a VPS on Vultr. Grabbed a TCPDUMP as you described (thank you!) Of course NOW it IS ringing so I’ll have to wait till it’s failing again. I made some changes last night to followme and stuff last night but I think it was intermittent before that too.

At least now I’m armed for when it does happen so thanks again @wmjackson

J.