Google voice Motif shows disconnected

I just set up FreePBX on a new box using Stable-4.211.64-8. I set up my google voice account and was able to make and receive calls when logged in to my google account on a PC. Next step, I plugged the account info into google voice motif and it shows disconnected.

After a lot of reading, I concluded there was nothing wrong with my setup, so I took the box home and tried it there, everything worked fine, took it back to work, disconnected

So this leads me to believe my ISP is filtering something. So my question is, what ports does motif use to connect to google chat…however that sounds strange as google chat works fine on my PC, including phone calls

The other possibility I can think of is that motif connects to an IP address vs through a dns name. I believe connections to IP addresses are blocked.

Can someone shed some light on this?

After working with my ISP, we determined that their filter saw it as jabber, and needed to be unblocked. interesting. works like a charm