Google Voice/Chan Motif cannot be installed

Hello I am getting the following error while trying to install the GV module:

Google Voice/Chan Motif cannot be installed:
Requires engine asterisk (>= 11), you have: asterisk 1.8.22.0
Please try again after the dependencies have been installed.

I’ve used your great script of converting my OpenVZ CentOS 6.4 to FreePBX Firmware 4.211.64-1

Could you please steer me in the right direction?
Thank you,

Anton

Let me wiki that for you : http://wiki.freepbx.org/display/FD/Changing+Major+Asterisk+Versions+on+the+Fly

You need to install asterisk 11. thats the only way it will work

Try running

asterisk-switch-version or asterisk-version-switch (cant remember off the top of my head)

Thank you guys for the quick response, it worked! I really appreciate your help and admire what you do with the whole project! If I ever start making money off of this it feels natural and easy to want to give back.

Are there any issues to be aware of if one switches to Asterisk 11?

Not off hand. It has been out for a good year now.

Well that didn’t go well. I followed the instructions at:
http://wiki.freepbx.org/display/FD/Changing+Major+Asterisk+Versions+on+the+Fly
and received the following fatal errors:

Regenerate FreePBX Dialplan for new Asterisk Version
[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting
Error(s) have occured, the following is the retrieve_conf output:
exit: 1
[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting

So now I have no clue as to what state my PBX is in, it seems to be working and it’s reporting Asterisk Ver. 11.5.1. I’m just nervious that these fatal errors are going to impact service in some way. Anyone know how to correct these errors?

run:
amportal stop
amportal start

Then retry. If that fails please post the output of: /etc/asterisk/manager.conf here

OK that went better this time, only thing I noticed was this after restarting Asterisk:

[[email protected] ~]# amportal stop

Please wait…

STOPPING ASTERISK
Waiting for Asterisk to Stop Gracefully…
Asterisk ended with exit status 0
Asterisk shutdown normally.

Asterisk Stopped

[[email protected] ~]# amportal start

Please wait…

SETTING FILE PERMISSIONS
Permissions OK
chmod: cannot access `/var/log/prosody’: No such file or directory
Removing any dangling symlinks
Dangling symlinks removed

STARTING ASTERISK
Asterisk Started
[[email protected] ~]#

I did mistakenly install Prosody, then removed it using:
yum -y remove prosody

Now I’m not a Linux expert and even less familiar with Centos, so I’m not sure why Asterisk is reporting this, should Prosody be installed? is there something I should do to satisfy Asterisk need for Prosody?

OK managed to install Prosody again and manually configure it.
I have the server running and users created, now to figure out if/how Prosody can be used with FreePBX?

I, too, am having trouble installing the Google Voice/Chan Motif module; on a fresh FreePBX Distro install. I've tried executing asterisk-version-switch twice, now; but each time Asterisk doesn't upgrade from v1.8.21.0. I even executed amportal stop, followed by amportal start, -- and tried asterisk-version-switch again -- to no avail. Each time, the OS downloads a bunch of software packages and eventually publishes something to the effect of 'Asterisk 11 installed successfully. Restarting to allow changes to take effect.' Yet, when I log into the web GUI and try to install the module, I encounter an error message stating that the module requires Asterisk v11 or above. Then, I execute cat /etc/asterisk/version, only to find that the system is still on Asterisk 1.8.21.0. Does anyone have any other suggestions? TIA, -Pablo