Google TTS - Problems nodejs

Hello,
I installed the Google-TTS like described here:

It seems that the propolly-tts.agi is not executing correctly. I get no messages from it in /var/asterisk/log/full

When I try to test in /opt/nodejs-text-to-speech/samples/ with node listVoices.js I get an error:
Error: yargs parser supports a minimum Node.js version of 10. Read our version support policy: GitHub - yargs/yargs-parser: the mighty option parser used by yargs
at Object. (/opt/nodejs-text-to-speech/samples/node_modules/yargs-parser/build/index.cjs:1007:15)
at Module._compile (module.js:653:30)
at Object.Module._extensions…js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)
at Module.require (module.js:597:17)
at require (internal/module.js:11:18)
at Object. (/opt/nodejs-text-to-speech/samples/node_modules/yargs/build/index.cjs:2855:16)
at Module._compile (module.js:653:30)

node -v returns v8.16.0

cat /etc/schmooze/pbx-version returns 12.7.8-2107-3.sng7

How can I upgrade node?

regards,
Gunther

Module is broken!

Means exactly what? Do I have to update nodejs or install something else?
Is a newer version of nodejs available for this freepbx distribution?

Ok, so nodejs 8 is deprecated since 2020. How can I update nodejs in my freepbx?

Anyone?

Let’s not worry about NodeJS at the moment, but if you’re really curious, just run yum remove nodejs then yum install nodejs.

In your PBX, go to Settings → Text To Speech Engines. If you have this menu, you should be able to add your TTS engine directly from here as polly is in this list.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.