Google Talk

hello all,

I am attempting to get inbound google talk (voice) connections into FreePBX. I have used the ISO installer and appear to have asterisk

When I attempt to place an inbound google call the console debug shows this:


JABBER: asterisk INCOMING: 24<caps:c node=“” ver=“1.1” ext=“pmuc-v1 sms-v1 vavinvite-v1” xmlns:caps=“”/>fad802ec2ce563e200bd8740e1a0905febd22c62

JABBER: asterisk INCOMING: 24<caps:c node=“” ver=“1.1” ext=“pmuc-v1 sms-v1 camera-v1 video-v1 voice-v1” xmlns:caps=“”/>fad802ec2ce563e200bd8740e1a0905febd22c62

JABBER: asterisk INCOMING: <jin:jingle action=“session-initiate” sid=“c217761660” initiator="[email protected]/gmail.C190B124" xmlns:jin=“urn:xmpp:jingle:1”><jin:content name=“audio” creator=“initiator”><rtp:description media=“audio” xmlns:rtp=“urn:xmpp:jingle:apps:rtp:1”><rtp:payload-type id=“103” name=“ISAC” clockrate=“16000”><rtp:parameter name=“bitrate” value=“32000”/></rtp:payload-type><rtp:payload-type id=“104” name=“ISAC” clockrate=“32000”><rtp:parameter name=“bitrate” value=“56000”/></rtp:payload-type><rtp:payload-type id=“119” name=“ISACLC” clockrate=“16000”><rtp:parameter name=“bitrate” value=“40000”/></rtp:payload-type><rtp:payload-type id=“99” name=“speex” clockrate=“16000”><rtp:parameter name=“bitrate” value=“22000”/></rtp:payload-type><rtp:payload-type id=“97” name=“IPCMWB” clockrate=“16000”><rtp:parameter name=“bitrate” value=“80000”/></rtp:payload-type><rtp:

JABBER: asterisk INCOMING: payload-type id=“9” name=“G722” clockrate=“16000”><rtp:parameter name=“bitrate” value=“64000”/></rtp:payload-type><rtp:payload-type id=“102” name=“iLBC” clockrate=“8000”><rtp:parameter name=“bitrate” value=“13300”/></rtp:payload-type><rtp:payload-type id=“98” name=“speex” clockrate=“8000”><rtp:parameter name=“bitrate” value=“11000”/></rtp:payload-type><rtp:payload-type id=“3” name=“GSM” clockrate=“8000”><rtp:parameter name=“bitrate” value=“13200”/></rtp:payload-type><rtp:payload-type id=“100” name=“EG711U” clockrate=“8000”><rtp:parameter name=“bitrate” value=“64000”/></rtp:payload-type><rtp:payload-type id=“101” name=“EG711A” clockrate=“8000”><rtp:parameter name=“bitrate” value=“64000”/></rtp:payload-type><rtp:payload-type id=“0” name=“PCMU” clockrate=“8000”><rtp:parameter name=“bitrate” value=“64000”/></rtp:payload-type><rtp:payload-type id=“8” name=“PCMA” clockrate=“8000”><rtp:parameter name=“bitrate” value=“64000”/></rtp:payload-type><rtp:payload-type id=“117” name=“red” clockrate=“8000”/><rtp:

JABBER: asterisk INCOMING: payload-type id=“106” name=“telephone-event” clockrate=“8000”/></rtp:description><p:transport xmlns:p=“”/></jin:content></jin:jingle><ses:session type=“initiate” id=“c217761660” initiator="[email protected]/gmail.C190B124" xmlns:ses=“”><pho:description xmlns:pho=“”><pho:payload-type id=“103” name=“ISAC” bitrate=“32000” clockrate=“16000”/><pho:payload-type id=“104” name=“ISAC” bitrate=“56000” clockrate=“32000”/><pho:payload-type id=“119” name=“ISACLC” bitrate=“40000” clockrate=“16000”/><pho:payload-type id=“99” name=“speex” bitrate=“22000” clockrate=“16000”/><pho:payload-type id=“97” name=“IPCMWB” bitrate=“80000” clockrate=“16000”/><pho:payload-type id=“9” name=“G722” bitrate=“64000” clockrate=“16000”/><pho:payload-type id=“102” name=“iLBC” bitrate=“13300” clockrate=“8000”/><pho:payload-type id=“98” name=“speex” bitrate=“11000” clockrate=“8000”/><pho:payload-type id=“3” name=“GSM” bitrate="

JABBER: asterisk INCOMING: 13200" clockrate=“8000”/><pho:payload-type id=“100” name=“EG711U” bitrate=“64000” clockrate=“8000”/><pho:payload-type id=“101” name=“EG711A” bitrate=“64000” clockrate=“8000”/><pho:payload-type id=“0” name=“PCMU” bitrate=“64000” clockrate=“8000”/><pho:payload-type id=“8” name=“PCMA” bitrate=“64000” clockrate=“8000”/><pho:payload-type id=“117” name=“red” clockrate=“8000”/><pho:payload-type id=“106” name=“telephone-event” clockrate=“8000”/></pho:description></ses:session>

For clarification, I’m not attempting to use google for outbound calls - just simply want to direct an inbound gtalk/jabber (jingle?) request to an extension on the phone switch.

Have you checked the jabber site they have had some DNS problems with google.

yes - I had a look and it appears on their site that they have no issues now, it just doesn’t work for me. Thanks for the suggestion though.

What doesn’t help is that I am no where near enough clear on how the inbound jabber communications are picked up by asterisk and turn into an inbound call. I have setup a gtalk trunk and inbound route but they seem to be light on detail and I’m mystified what magic takes place to make this work. Before anyone helpfully points out rtfm I have started, but oddly enough there is quite a lot of material to wade through before evening getting close to google / jabber !

Anyone else?

PS- I did originally paste a lot more of the jabber debug screen, it just doesn’t seem to want to show up in the posting :frowning:

Which config files have you edited ?

Here is an older how-to :

In general freepbx wants to edit some files but may not do all like jabber.conf

Thank you - still not sure exactly how, but the envisioning site had some differences on the dial plan context setup (specifying the google account name on each line) and this appears to have fixed it.

Now I have something to both reverse engineer to help understand better and to build on to get IVRs and touch tones working! let alone the ability to establish outbound gtalk connections.