Give Misc Destinations a number

How can you set a number to the Misc Destinations.
When I set it up for calling my mobile phone. I see ony a private number when I get called

Can you please try explaining again what you are trying to do?

By default, calls forwarded to an external number try to display the number of the original caller as caller ID. There are several common reasons why this doesn’t work correctly.

If you don’t need this functionality (you will display your company number on the mobile), set up an Outbound Route with a special prefix that has the company number as Route CID and Override Extension checked. Set the Misc Destination to use that route (by specifying the correct prefix). Or, route the incoming call through a Set CallerID app, then to the Misc Destination.

However, if you want to show the number of the original caller, you will need to find out what’s wrong and fix it. There are three common causes:

  1. Your trunking provider does not allow you to send a number that’s not yours. In that case, you will need a different provider for these calls. I recommend AnveoDirect or Voxbeam; both provide a small credit at signup, so you can test without making a payment.

  2. Your trunking provider has special requirements for these calls, e.g. sending a Diversion header or signing a waiver. Find out the details from them and adjust your trunk settings accordingly.

  3. Your trunking provider requires the calling number to be in a different format from what you are sending. You can rewrite the caller ID with a custom context, passing the incoming call through a Set CallerID app, etc.

Misc Destinations will dial whatever destination you set as if a user/device dialed it normally. This is not a Call Forward in any ways. The call will be treated like any other call a user would make from their phone. So this means:

  1. It will hit the Outbound Routes like normal. Match like normal.

  2. It will use the CallerID details in the Outbound Route and/or Trunk it uses. If the CallerID details are 100% on the endpoint’s Outbound CallerID setting, there is no Outbound CallerID set.

  3. The inbound side of the call is bridged once the Misc Destination answers. So this is treated like A called B. That’s it and none of the channel variables from A (CallerID, etc) are set on the channel for B (the sip trunk side).

So if you are looking to “forward” calls through the PBX and use the original caller’s CallerID then you need another method. This will not work.

You could create a Custom Extension and set its Dial setting to SIP/trunkname/destination and that will do what you want while treating it like an Inbound Call to the Extension. In other words, CallerID should be passed.

@BlazeStudios I apologize; you are 100% correct. I did some Misc Destination testing with FreePBX 14 and found that Route CID is used, even if Override Extension is off. If Route CID is not present, Outbound CallerID for the trunk is used, even if Allow Any CID is set. I did not test the case of Outbound CallerID absent, because that’s IMO not suitable for a production system.

@daansk44 As Tom says, if you want the company number to be displayed, put it in the Outbound CallerID for the trunk; you want this for other reasons anyway. If you want the original caller’s number, set up a Custom Extension as he says; if it doesn’t work see my previous post for troubleshooting.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.