Getting Wrong Password Error using Polycom 330

For some reason I keep getting a wrong password error:

[2014-09-12 11:30:42] NOTICE[2341]: chan_sip.c:27627 handle_request_subscribe: Failed to authenticate device “Testy” sip:[email protected];tag=1936950E-1C195E13 for SUBSCRIBE
[2014-09-12 11:30:53] NOTICE[2341]: chan_sip.c:28003 handle_request_register: Registration from ‘sip:[email protected]’ failed for ‘10.1.16.163:5060’ - Wrong password

Here’s part of the Polycom 330 Configuration File:

<reg
  reg.1.displayName="Testy"
  reg.1.address="504"
  reg.1.server.1.address="10.1.16.253"
  reg.1.server.1.port="5060"
  reg.1.server.1.register="1"
  reg.1.server.1.expires="3600"
  reg.1.label="Testy"
  reg.1.type="private"
  reg.1.thirdPartyName=""
  reg.1.auth.userId="504"
  reg.1.auth.password="3a8beae97602c0555fe80b38091da557"

  reg.1.outboundProxy.address=""
  reg.1.outboundProxy.port="5090"
  reg.1.outboundProxy.transport="UDPOnly"
  reg.1.ringType="2"
  reg.1.lineKeys="1"/>

Here’s the entry in sip_additional.conf

[504]
deny=0.0.0.0/0.0.0.0
secret=3a8beae97602c0555fe80b38091da557
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp
avpf=no
icesupport=no
encryption=no
callgroup=
pickupgroup=
dial=SIP/504
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=Testy <504>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

They’re both matching so I’m not sure why it’s happening. Both the phone and the pbx is behind a TZ 215 firewall on an internal network.

It looks like it is trying to authenticate as tasty not 504

Not sure where you see that James. Auth ID is 504

Password might be too long for the old Polycom firmware on that model.

Give or take the odd typo, he sees it here:

[2014-09-12 11:30:42] NOTICE[2341]: chan_sip.c:27627
handle_request_subscribe: Failed to authenticate device “Testy
;tag=1936950E-1C195E13 for SUBSCRIBE

May have been hungry

You probably want

auth=md5

in your [504] extension settings

I originally had a shorter password and it didn’t work. I also have updated the firmware via the endpoint package manager. I’m not sure where to set auth=md5. I don’t see that option in the extensions settings within FreePBX.