Getting DID to work in freepbx 14

Fairly new, I am using freepbx 14 and am having a little trouble getting the DID to work.
Every works fine in an all incomming route, but when I try setting up a did for one of my numbers I get a this number is not connected message? I there anywhere in freepbx do I adjust it or do I have to go into Asterisk?

You need to show us logs so that we can determine why it isn’t working

Sorry avayax, I am not sure which log? Is it one I generate with asterisk through the CLI or is it one on the server under asterisk. I had a look at the one under the Asterisk… directory and it seemed to be a lot of garbage?

Yes, look at the Asterisk CLI, make the call, and paste what your see there.

Under “Reports” you have a item called “Asterisk Log Files” there you have the log

res_pjsip_exten_state.c:356 new_subscribe: Extension state subscription failed: Extension *69 does not exist in context 'from-internal’
Is that something to do with an ip address? ,but the “*69” ??

The solution to DID alocation was simple!
In setting up the trunk: instead of the default setting of "from-pstn"
I changed it to “from-pstn-toheader”
(in case someone else has this problem)