G729 issue on inbound causing One Way Audio

Strange situation: I loaded 6 G729 codecs on server. I use them specifically for one client that uses an ATA.

Other client - lets call him Bob. He has 4 sip devices with ext 301, 302, 303 and 304. I set all the ext to ring on a ring group when the main DID is dialed. In astersik CLI, I can see a warning message that says the G729 codec is out of licenses. Then, when bob answers his phone, he can be heard, but he can not hear the calling party.

So I go into Asterisk Sip settings, disable the g729 codec, all works well.

In the sip devices I have u711 selected

In the freepbx ext it says disallow=all and allow = ulaw

Why is it trying to use g729 under these settings? It should go right to 711 the way I have it configured?

Each leg on a call needs one g729 license if you are bridging not “passing-through” the RG is a potential bunch of bridges, you would need 8 licenses

I don’t want to use g729 for “bob’s” phones. It is trying to use G729 and I show 711 in sip device and disallowed all and allowed 711 in ext in freepbx.

Despite this, it is trying to use G729 when Bob gets an incoming call. I want it to use 711

did you allow 711 or allow ulaw? g711u is ulaw in asterisk.
if so… also try doing the same for the trunk/peer
in Trunk and Extension try:

has to be in that order. Disallow first and allow second.


Mike :slight_smile:

I ended up removing g729 codec from server until I can figure out the issue. All settings in trunks and sip devices prohibit g729 but it attempts to use it anyway. Thread closed for now.