Fyi - Advanced Installation boohs

Just some point who I encountered trying to install the lastest Distro SNG7-FPBX-64bit-1710-1.iso.

I tried to use the advanced mode becaus I like to change some default values not fitting when using the automatic install, namely:
fixed IP
different name
different timezone
different keyboardlayout

I think these should be applied before anything else is done, even before registering the host.
But you need to register the host to use even the “free” Systemadmin module were you can change IP to static an all the other stuff (as far as I read).
But without change of the IP I can’t register (the network guy is patroling here), so I have a Henne-Ei-problem (how is it called in english chicken-egg-problem?).
Ok so use the commandline, does FreePBX reflect all changes done on cli?

Ok some “bugs” I encountered.
1.) bootloader was not installed, The install went fairly through after a reboot - nothing. I booted to the “recovery options” from usb, chroot in the system made a grub2-install, system booted - fine.
2.) keyboard was partly wrong. Was set in the dialog during install to “de”. Setting was only made for X11 not for the console - keep that in mind when typing the password …
3.) networking. I noticed after login in the console that no ip was assigned, albeit entered in the installation dialog. Ok the auto install uses the old devicenames “eth0, ppp0, …” when installed in advanced mode the new names “ens0p…” are used so the interface wasn’t configured at all, can FreePBX handle the new naming convention?

So I finally have to wait for my network guy, to give me a dhcp assingment with which I’m allowed to register the installed host, for setting up the basic things.

For the future it would be nice when the advanced install will work flawless like the automated install.


p.s.: it is a rhel/centos thing I know, but this is a combined work from here so it’s quite clear that people complain here and not at redhat’s place
p.p.s.: if you find some typos, feel free to keep them, my mother tongue is not english