FXOTUNE Failure

configuration
Tags: #<Tag:0x00007fafc1e1ba40>

(Nice Guy) #1

All of a sudden static is now being heard on calls. I used the “FXOTUNE” command before to get this resolved but now it is not working out to well.

[root@freepbx ~]# fxotune -i -n 4 -b 1 -e 4 -p -vvv
Failed to open /dev/dahdi/ctl: No such file or directory
Failed to open /dev/dahdi/ctl: No such file or directory
Failed to open /dev/dahdi/ctl: No such file or directory
Failed to open /dev/dahdi/ctl: No such file or directory
fxotune: successfully set echo coeffecients on FXO modules

Any help on resolving this would be really appreciated .


#2

Dahdi neds to be running but asterisk needs to be stopped for fxotune to work. But it will not resolve “static” it is just to ‘balance’ the 2-4 wire hybrid between the PSTN and the rx/tx nature of Asterisk


(Nice Guy) #3

yes I am aware i ran the “service asterisk stop” before attempting to tune.

You do have more knowledge of the freepbx than me but it is a fact that this stopped static on the lines once if I can recall correctly


#4

Asterisk is a ‘service’ as is dahdi they are not the same service , we don’t know how you installed your system but if /dev/dahdi is not extant, then dahdi is just not running. Perhaps

service dahdi status

Would be edifying , perhaps

service dahdi start

if necessary? Perhaps you are using systemd perhaps you are using a distro.

It depends on your definition of static, generally that means extraneous crackles or other audible artifacts, fxotune won’t fix that, what it does is investigate the impedance and relative levels of the FXO line (the 2 wire side of the hybrid) by sending an impulse and watching the resultant echo ‘tail’, then informing asterisk as to how to adjust the tx/rx gains (the 4 wire side of the bridge) it sets the individual dahdi channels to.


(Nice Guy) #5

well I guess it could have all been coincidental.
But it seems that the command I used to stop asterisk was not working fully. I tried another method.

I went into asterisk cli and stopped it from there, then ran the fxotune and it seemed to have work… if the issue is resolved i will put an update.

So in the meantime what can I do about the static?


#6

Stick a five dollar phone from Walmart on the CPE jack outside your home, if there is still static, call the Telco repair. Repeat at the pbx demarc if suddenly there, check your interconnects to the CPE, if not then the obvious remody is replacement of hardware individually until the problem goes away.

Edit: have you as yet “wiggled” all your hardware interconnects , oxidation and possible derivative semi-conduction can spoil your whole day when using copper/other metal connections, but the mechanical deformation (wiggleing) itself will often expose audible ‘static’ if so prone.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.