FXO Handset cant access trunk


I am using Freepbx with a Sangoma Vega50 which has 2 FXO and 4 FXS in use. The Vega is running the latest version of firmware that is available publically.

If any of the FXS handsets (all using SIP) attempt to access the external trunks (via the Vega or a SIP trunk) to place a call, they appear to get handled as an inbound call and are presented to the default inbound route (the group extensions ring).

All IP (PJSIP) handsets can communicate with the FXS handsets - and everything works both directions between these extensions.

All the IP handsets can make and take calls through to the FXO lines attached to the Vega or indeed the SIP trunk too…

Any inbound calls from the Vega provided FXO can be answered and work perfectly from an Vega FXS handset (or and IP one).

I have tried to digest the logs to establish what is going on here, but have really drawn a blank.

Does anyone have ideas as to what could be wrong?

Any help is very much appreciated.


Do you have Custom Context set for the extensions in question? If so, try setting to Allow All.
Or, if using Extension Routes or Class of Service, confirm that you aren’t restricting them there.

Otherwise, make a failing test call, paste the relevant section of the Asterisk log at pastebin.freepbx.org and post the link here.

Stewart - thanks for the quick reply.

The FXS Extensions are all “from-internal”. I tried setting the extension context to “allow-all” and it made no change to the issue.

The Vega50 was working for years with Elastix (freepbx 11,13,9) and never had an issue and it was “all my fault” as my wife would say, that its broken when I moved over to a new host and a current release of freepbx!

As an aside, when reconfiguring the vega50 to the new freepbx instance, I changed the relevant port and IP addresses and nothing else from memory - so that the original “working” config was preserved as best I could.

I will post logs later.



Sorry for the late reply.

I have inserted an mage rather than the full log as I hope it is sufficient to see what is happening - its not easy to see (for me!) what is the call setup from the handset and what is the incoming call that is being presented.


The Vega FXS are using CHAN_SIP on 5160 - with context of from-internal, friend.


In spite of that, the calls are being processed by pjsip, causing your trouble.

In Asterisk SIP Settings, chan_pjsip tab, Port to Listen On (default 5060) is the local port for pjsip. On the chan_sip tab, Bind Port (default 5160) is the local port for chan_sip. If you change these, you must restart (not just reload) Asterisk.

On the Vega, I believe that the port it sends INVITEs to is specified by port=xxxx under [sip.profile.x.proxy.1] ; edit the profile(s) used by the FXS ports. However, the Vega has many complex settings and something (outbound proxy, DNS SRV, etc.) could be overriding that.

Also, if incoming FXO calls are also going through pjsip, fixing the above problem might cause these calls to stop working and you’ll need to fix that separately. Using different SIP Profiles for FXS and FXO should avoid this issue.

If you still have trouble, running sngrep or tcpdump will show you where the INVITEs are going.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.