FXO adapter

Do you know of a small inexpensive FXO adapter device (not a card) that just works?


Cisco SPA3102, Grandstream HT-503. They work, not sure how cheap or expensive they might be for you, but those are probably the cheapest, as they have only 1 fxo port and 1 fxs port.

Also Obihai OBi110. All three are EOL products but available used at very low cost.

Current products include Obihai OBi212 and Grandstream HT813.

There are TONS of them. Look for “ATA” and “MTA” devices, in addition to the FXO/FXS search that yields the usual suspects.

Thanks. Ordered a Grandstream HT813.

Does anybody have FreePBX setup instructions?

Grandstream itself has one, on the Support section of their website for the product.

I had looked for it earlier and looked again now, but I did not find one.

I assume I need to make it a trunk.

Indeed you need a trunk.

Even though is for the gxw4104, the configuration is almost the same, except there are less ports.

Great! Thank you.

I now have a brand new Grandstream HT-513. ($47.50)

Trying to configure. I looked at the manual above and googled around. There are various posts, but they are use different ways.

The manual above if for pure asterisk, so I have no clue how to do that using the FreePBX Gui.

Do I use a chan_sip trunk or a chan_pjsip trunk?

Also, it talks about “using SIP accounts.” “In the sip.conf file, add SIP accounts”. No idea where that is.

I do not want to go over and extension, just want to use it as a trunk that I can configure in inbound and outbound routes.

Also, sometimes it talks about type=peer and sometimes about type=friend.

Lost …

Thanks for all your help!


I can help you configure it f you want.

You can also use this as a guide. Even though it is for the old trixbox system, it should help you start.

Thanks. I am trying hard, but I am overlooking something.

Insecure parameter should be

Port parameter should be

And type could be friend an context likely from-internal you don’t need a user/password on a lan

For the FXO port on the ht503 it is good to have from-trunk, so the incoming calls from the PSTN side can be treated as such.

Thanks for all your help. I have tried all these versions, but I guess with no success.

How should I see that everything is properly registered? I can’t find anything with that IP in my logfiles.

This should not be hard to troubleshoot.

I recommend that you set up the HT to register to your PBX. I have two similar devices (SPA3102 and OBi110) on my system.

Try these chan_sip trunk settings:


In the HT, set Authenticate Password to match what you chose for secret in the trunk (1234 in this example). Set SIP Registration to Yes.

If your PBX has chan_sip binding to port 5160 (the default), change the Primary SIP Server to and SIP Destination Port (in Call Forward setting) to 5160. Of course, if you changed the PBX settings to have chan_sip on port 5060, leave those alone.

With luck, the FXO light on the HT should be solid blue and the PBX should show the peer as available. If not, report what (if anything) gets logged on the attempted registration and any useful info on the HT’s Status page.

If it registers ok, report what happens on outgoing calls, and on incoming.

Great. That brings me a big step forward.

Blue light now. FXO shows as registered. Incoming calls arrive and can be properly routed.

Outgoing do not yet work.

[2019-08-11 09:54:10] VERBOSE[22623][C-00073681] app_dial.c: Called SIP/xxxxxxxxxx/[email protected]
[2019-08-11 09:54:10] VERBOSE[22623][C-00073681] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
[2019-08-11 09:54:10] VERBOSE[22623][C-00073681] pbx.c: Executing [[email protected]:25] NoOp(“SIP/1102-0000134c”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 21”) in new stack

Debug the peer so you can see the actual error.

How do I do that?