Fwconsole start is failing and asterisk can't connect

Hi all,

I’ve been trying to debug why asterisk will not load following an sysadmin pro automatic upgrade from 10.13.66-5 to 10.13.66-7. The system got locked somewhere during the 10.13.66-6 script, so I unlocked the upgrade using/usr/sbin/sysadmin_update_system --unlock and followed with /usr/sbin/sysadmin_update_system, which failed:

[[email protected] ~]# /usr/sbin/sysadmin_update_system
Array
(
    [status] => ok
    [data] => Array
        (
            [10.13.66-6] => Array
                (
                    [url] => http://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-6.sh
                    [changelog] => 
                )

            [10.13.66-7] => Array
                (
                    [url] => http://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-7.sh
                    [changelog] => 
                )

        )

)
running http://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-6.sh
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

I ran the upgrade scripts manually to set what errors might appear and both times the following appeared at the end of stage 1:

Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 1
Exception: Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting in file /var/lib/asterisk/bin/retrieve_conf on line 13
Stack trace:
  1. Exception->() /var/lib/asterisk/bin/retrieve_conf:13

It seems like asterisk can’t start… I checked to make sure mysql is running and that the passwords are the same in /etc/asterisk/manager.conf and /etc/amportal.conf. When I run fwconsole start I get the following

[[email protected] ~]# fwconsole -vvv start
Running FreePBX startup...
Setting Permissions...


                                     
  [InvalidArgumentException]         
  The "full" option does not exist.  
                                     


Exception trace:
 () at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Symfony/Component/Console/Input/Input.php:180
 Symfony\Component\Console\Input\Input->getOption() at /var/www/html/admin/libraries/Console/Chown.class.php:264
 FreePBX\Console\Command\Chown->execute() at /var/www/html/admin/libraries/Console/Start.class.php:66
 FreePBX\Console\Command\Start->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Symfony/Component/Console/Command/Command.php:257
 Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Symfony/Component/Console/Application.php:874
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Symfony/Component/Console/Application.php:195
 Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Symfony/Component/Console/Application.php:126
 Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:132


start [args1] ... [argsN]

Any ideas? Thanks in advance for everyone’s time.

fwconsole ma upgrade framework
fwconsole start

Thank you for the quick response! Upgrading the framework module seems to have resolved the issue.

There is a new notification, however, that I cannot seem to resolve:

I ran amportal chown as suggested and then opened the DAHDi Config Module, but the notification reappears (I had dismissed it just to be sure). Anything else I need to do?

That fixed mine. I had the same issue. Thanks for the rapid resolution.

@tm1000 This Helped a lot thank you

I have tried the following but did not work;

  1. Check Password in /etc/asterisk/manager.conf
  2. Check Password in /etc/amportal.conf
  3. Rebooting Server

I had to change the owner of /var/lib/asterisk/astdb.sqlite3 from root to asterisk.
chown asterisk:asterisk astdb.sqlite3
The owner had gotten changed when I was messing with the astdb.sqlite3.

1 Like