Fwconsole services doesn’t start when system booting

Hi all! I have realized that fwconsole services doesn’t start automatically on system boot. I have to do a fwconsole start and all services seem to be stoped.

I’m not sure when started to happen, but I think it started happening after a module upgrade, time ago.

It is a Freepbx 15.

Any idea about this?

Regards.

This might help -

Thanks Davis,

I tried to change rc.local but it didn’t work for me.

Any suggestion?

Regards

Personally, I would try to hunt down what is broken and fix that. If it’s related to a module, you can update your modules fwconsole ma update modulenamehere

In the GUI under admin, module admin allows you to revert a module version. Go there and select “check online.” Go to the desired module, click on previous, and you will see rollback options for reversion.

I wouldn’t consider this step a real solution when a potential module issue still needs to be resolved, but you could run a script on boot. An fwconsole restart would probably be fine.

I suppose you could do something like this using your favorite text editor. I prefer vim. I haven’t tested if I have the correct directory location below, but I think this will work.

Create a script file in the appropriate directory

vim /etc/rc.d/init.d/myfwstart.sh

File Contents

#!/bin/bash 

/usr/sbin/fwconsole restart

Make Script Executable

chmod +x /etc/rc.d/init.d/myfwstart.sh

Thanks Daivd, will try to do this. I only can try it on maintenance reboots, so I have to wait for a maintennance.

I will feed back when done.

Regards.