Fwconsole restart fails into restart and asterisk remains shutdown

FreePBX v13 updated to most recent release. Updated with latest modules in edge.

We issue an fwconsole restart weekly (srtp issue requires periodic restart). Now fwconsole restart fails after starting command and leaves asterisk in not running state. Output reads as such:

[[email protected] ~]# fwconsole restart
Running FreePBX shutdown…

Stopping UCP Node Server
Stopped UCP Node Server
Stopping Chat Server
Stopped Chat Server
Stopping Zulu Server
Stopped Zulu Server
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] 1 sec

[Exception]
Hook file ‘/var/spool/asterisk/incron/firewall.stopfirewall’ was not picked up by Incron after 5 seconds. Is it not running?

restart [-i|–immediate] [args1] … [argsN]

Must then issue an fwconsole start, while it does start, there is a noted exception:

[[email protected] ~]# fwconsole start
Running FreePBX startup…
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissions…
Setting base permissions…Done
Setting specific permissions…
25213 [============================]
Finished setting permissions
Running Asterisk pre from Firewall module
Hook file ‘/var/spool/asterisk/incron/firewall.firewall’ was not picked up by Incron after 5 seconds. Is it not running?
Running Asterisk pre from Sysadmin module
Running Sysadmin Hooks
Restarting fail2ban
fail2ban Restarted
Updating License Information for 17497836
Checking Vpn server
Starting Asterisk…
[============================] 5 secs
Asterisk Started
Running Asterisk post from Endpoint module
Running Asterisk post from Pagingpro module
Running Asterisk post from Ucpnode module
Starting UCP Node Server…
[>---------------------------] 2 secs
Started UCP Node Server. PID is 11436
Running Asterisk post from Xmpp module
Starting Chat Server…
[>---------------------------] 1 sec
Started Chat Server. PID is 11559
Running Asterisk post from Zulu module
Starting Zulu Server…
[>---------------------------] 1 sec
Started Zulu Server. PID is 11628

Concerned that restart fails. Concerned that a start yields a “firewall.stopfirewall was not picked up by Incron…”

Run the following. Worked for me.
fwconsole ma downloadinstall firewall
fwconsole reload
(If it does not work, try a system reboot)

1 Like

I will try that (after hours) - but the firewall is loaded and running now.

Well… I ran the command to redownload the firewall, then I ran the command fwconsole restart && fwconsole reload. Again got the error.

Then I rebooted and multiple times ran the command fwconsole restart && fwconsole reload with success. I do not understand why this was necessary, but am happy we can again “restart asterisk / freepbx” without issue.

1 Like

The error is saying that Incron is not running. You need to re-enable incron (someone has disabled it).

How do you en-enable Inchon?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.