Fwconsole r error

[[email protected] ~]# fwconsole r
Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 255
PHP Fatal error:  Cannot use object of type DB_Error as array in /var/www/html/admin/modules/manager/functions.inc.php on line 71
Whoops\Exception\ErrorException: Cannot use object of type DB_Error as array in file /var/www/html/admin/modules/manager/functions.inc.php on line 71
Stack trace:
  1. () /var/www/html/admin/modules/manager/functions.inc.php:71

That’s a known issue - you can fix it with this:

[[email protected] ~]# fwconsole ma install -f manager

That’ll re-install it and fix the error. We know what the problem is, but the solution may not be simple 8-\

–Rob

1 Like

thnx. it works.
now i have another problem

[[email protected] ~]# fwconsole ma listonline
No repos specified, using: [standard,extended,commercial] from last GUI settings

  [PDOException]                                                                                         
  SQLSTATE[08S01]: Communication link failure: 1153 Got a packet bigger than 'max_allowed_packet' bytes  
                                                                                                         


ma [-f|--force] [-d|--debug] [-j|--json] [-R|--repo="..."] [args1] ... [argsN]


[[email protected] ~]#

I had the same issue with the max_allowed_packet error. This worked:

edit the file: /etc/my.cnf

and add to the following section:

[mysqld]
max_allowed_packet=16M

Save, then restart MySQL using: /etc/init.d/mysqld restart

Not sure what the recommended value for the packet size is, but 16M worked for me.

1 Like