Fwconsole not starting asterisk

here is the console output
e asterisk (does /run/asterisk/asterisk.ctl exist?)
[[email protected] asterisk]# fwconsole start
Running FreePBX startup…
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissions…
Setting base permissions…Done
Setting specific permissions…
31523 [============================]
Finished setting permissions
Starting Asterisk…
[--------------->------------] 31 secs
In Start.class.php line 189:

Unable to connect to Asterisk. Did it start?

start [–pre] [–post] [–skipchown] [–] []…

I believe its because I need to have the lib directory & spool in a diferetn place.

However asterisk will start if I tel systemd to start it.

Any ideas on what i need to fix. Asterisk does start with systemd as well as asterisk -c start at command prompt.

I’m curious if this is on a fresh install or if it’s on an old system that’s no longer working. If it’s a fresh install, which Distro are you using? Is it the SangomaOS?

Its Rhel 7, on a new install It worked for a few days until updates were done.

Do you know if asterisk is started on boot up? I’m curious if Asterisk has been started, but started under the incorrect user. If you execute ps auxf | grep asterisk on the console, what does it say?

[[email protected] ~]# ps auxf |grep asterisk
root 13941 0.0 0.0 112812 972 pts/2 S+ 10:38 0:00 _ grep --color=auto asterisk
asterisk 2159 0.1 0.2 609940 45312 ? S Apr08 2:47 _ /usr/sbin/httpd -DFOREGROUND
asterisk 6198 0.1 0.2 605456 40232 ? S Apr08 2:06 _ /usr/sbin/httpd -DFOREGROUND
asterisk 14805 0.1 0.2 608112 42844 ? S Apr08 1:56 _ /usr/sbin/httpd -DFOREGROUND
asterisk 14869 0.1 0.2 602060 37440 ? S Apr08 1:38 _ /usr/sbin/httpd -DFOREGROUND
asterisk 15487 0.1 0.3 697524 50852 ? S Apr08 2:33 _ /usr/sbin/httpd -DFOREGROUND
asterisk 30137 0.1 0.3 710144 61388 ? S Apr08 2:39 _ /usr/sbin/httpd -DFOREGROUND
asterisk 32256 0.1 0.3 614856 51800 ? S Apr08 1:44 _ /usr/sbin/httpd -DFOREGROUND
asterisk 17477 0.0 0.2 603344 37784 ? S Apr08 0:49 _ /usr/sbin/httpd -DFOREGROUND
asterisk 6311 0.0 0.3 615404 51976 ? S Apr08 0:56 _ /usr/sbin/httpd -DFOREGROUND
asterisk 19245 0.0 0.2 601516 37924 ? S 07:37 0:01 _ /usr/sbin/httpd -DFOREGROUND
asterisk 15093 0.0 0.2 639764 41932 ? Ssl Apr08 0:46 PM2 v2.10.6: God Daemon (/var/lib/asterisk/.pm2)
asterisk 15149 0.0 0.1 664936 26944 ? Ssl Apr08 0:19 _ node /var/www/html/admin/modules/core/node/fastagi-server.js
asterisk 13496 0.7 0.2 759744 45560 ? Ssl 10:37 0:00 _ node /var/www/html/admin/modules/ucp/node/index.js
asterisk 31352 0.2 0.8 3045932 133792 ? Ssl Apr08 3:42 asterisk -G asterisk -U asterisk -C /etc/asterisk/asterisk.conf -g -vvv -F

Anyone have ideas why it won’t start

It’s running - right there.

If this isn’t the daemon you started (for example, if you started one by hand or have systemd starting it) then it might not be set up for FreePBX to manage it.

Maybe disable asterisk start on boot up and see if that fixes it? FreePBX may want to be thing thing that wants to start it I believe.

systemctl disable asterisk

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.