Fwconsole not found

Not sure if this is related or not. My customer can no longer get to the user portal. I SSH’d into the system and I got this: The system is 6.12.65-32


Unable to generate MOTD.
The /usr/sbin/fwconsole file is not accessible

You are likely to experience significant system issues.

[[email protected] ~]#

I looked in /usr/bin for the fwconsole file and it isn’t there.

Logging into the system I have the following errors:
Unable to write to /etc/dahdi/system.conf

The Errors in the System Overview
/etc/dahdi/system.conf is not owned by Asterisk
/etc/dahdi/modules is not owned by Asterisk

As far as I know the system is still running.

What do I need to do here?

^ “/usr/sbin”

^ “/usr/bin”

Different directories.

Not in that /usr/bin either. The previous error is a screen capture from the SSH session screen. I have looked in both directories and the file is not there…

Do you realize what you are saying??? You keep repeating the same argument. Please look in “/usr/SBIN”

I looked in /usr/sbin there is no fwconsole file. There is no directory /usr/SBIN BTW. I thought you were telling me to look in /usr/bin for the file. Could an automatic update have gone sideways?

That is VERY bad. All system level binaries sit in there. If that doesn’t exist you’ve got a broken system on your hands.

Well, I have two of them then. One of our sales guys just handed me a screen shot of the same error message on a system we shipped and that is in a production environment. What is the resolution??? I fear that there might be more of them. This new one is at 6.12.65-32

Did you check /usr/sbin? or /usr/SBIN. I capitalized SBIN to put emphasis on it but you need to remember that linux is a case sensitive machine.

I was just told about the Dahdi file … not owned by Asterisk issue is on several of some of the other systems we have out there. Our sales engineer has been seeing this for a couple of days

Yeah I know that Linux is anal about that. I logged into our system and it wsn’t there either so I pretty much caught you were putting an emphasis on it :slight_smile: All good

1 Like

Running fwconsole chown will fix the error with asterisk not being able to write to /etc/dahdi/system.conf, /etc/dahdi/modules

I know you can’t run that though. Is everything else on the system working without /usr/sbin?

Maybe I didn’t make the issue clear. fwconsole is missing from the /usr/sbin directory. There are many other files in there. The systems APPEAR to be running OK.

run amportal. It’ll place fwconsole to the right location.

What argument “restart”?

amportal chown. Paste output here.

Using username “root”.
[email protected] password:
Send automatic password
Last login: Fri Feb 19 13:45:46 2016 from


Unable to generate MOTD.
The /usr/sbin/fwconsole file is not accessible

You are likely to experience significant system issues.

[[email protected] ~]# amportal chown

Fetching FreePBX settings with gen_amp_conf.php…

Removing any dangling symlinks
Dangling symlinks removed
[[email protected] ~]# cd /usr/sbin
[[email protected] sbin]# ls
acpid postalias
addgnupghome postcat
adduser postconf
alternatives postdrop
anacron postfix
apachectl postkick
applygnupgdefaults postlock
arpd postlog
arping postmap
astcanary postmulti
astdb2bdb postqueue
astdb2sqlite3 postsuper
asterisk pwck
astgenkey pwconv
astribank_allow pwmconfig
astribank_hexload pwunconv
astribank_is_starting quota_nld
astribank_tool quotastats
authconfig raid-check
authconfig-tui randpkt
autosupport rasterisk
avahi-daemon rawshark
avcstat readprofile
biosdecode repquota
brctl restorecond
build-locale-archive rotatelogs
cacertdir_rehash rpc.rquotad
cache_check rtacct
cache_dump rtcwake
cache_repair run_init
cache_restore safe_asterisk
capinfos safe_finger
capsh saslauthd
chpasswd sasldblistusers2
chroot saslpasswd2
ck-log-system-restart schmooze_findreplace
ck-log-system-start selinuxconlist
ck-log-system-stop selinuxdefcon
clockdiff selinuxenabled
console-kit-daemon semodule
convertquota sendmail
cracklib-check sendmail.postfix
cracklib-format sensors-detect
cracklib-packer sestatus
cracklib-unpacker setcap
create-cracklib-dict setenforce
crond sethdlc
dahdi_cfg setquota
dahdi_genconf setsebool
dahdi_hardware sim_server
dahdi_maint smtp-sink
dahdi_monitor smtp-source
dahdi_registration snmpd
dahdi_scan snmptrapd
dahdi_span_assignments ss
dahdi_span_types sserver
dahdi_speed sshd
dahdi_test suexec
dahdi_tool sysadmin_amportal_restart
dahdi_waitfor_span_assignments sysadmin_create_user.sh
dftest sysadmin_dahdi_restart
dmidecode sysadmin_dns
dnsmasq sysadmin_email_setup
dumpcap sysadmin_ftp
e2freefrag sysadmin_ha
editcap sysadmin_hostname_setup
edquota sysadmin_intrusion_detection
efibootmgr sysadmin_intrusion_detection_banned
era_check sysadmin_intrusion_detection_restart
era_dump sysadmin_mdadm
era_invalidate sysadmin_network
ethtool sysadmin_openvpn
fancontrol sysadmin_phone_config
fdformat sysadmin_portmgmt
filefrag sysadmin_queuecallback_restart
fxotune sysadmin_restapps_restart
genccode sysadmin_restart_httpd
gencmn sysadmin_time_zone
genhomedircon sysadmin_update_set_cron
gensprep sysadmin_update_system
genuca sysadmin_ups
getcap sysadmin_wanrouter_restart
getenforce sysadmin_xmpppresence_restart
getpcaps system-config-network
getsebool system-config-network-cmd
glibc_post_upgrade.i686 system-config-network-tui
groupadd sys-unconfig
groupdel t1libconfig
groupmems tcpd
groupmod tcpdump
grpck tcpslice
grpconv testsaslauthd
grpunconv tethereal
gss-server text2pcap
hald thin_check
htcacheclean thin_dump
httpd thin_metadata_size
httpd.event thin_repair
httpd.worker thin_restore
httxt2dbm thin_rmap
hwclock tickadj
iconvconfig tmpwatch
iconvconfig.i686 togglesebool
icupkg tracepath
incrond tracepath6
in.tftpd try-from
isadump tshark
isaset tunelp
lchage twinstar
ldattach tzdata-update
lgroupadd update-alternatives
lgroupdel update-pciids
lgroupmod useradd
lid userdel
lnewusers userhelper
lnstat usermod
load_policy usernetctl
logrotate uuserver
lokkit vigr
lpasswd vipw
lsdahdi visudo
lsof vpddecode
lsusb vsftpd
luseradd wan_aftup
luserdel wancfg
lusermod wancfg_dahdi
makewhatis wancfg_data_api
matchpathcon wancfg_fs
mergecap wancfg_fs_legacy
mkdict wancfg_ftdm
mklost+found wancfg_hp_tdmapi
mksock wancfg_legacy
mtr wancfg_openzap
newusers wancfg_smg
nstat wancfg_tdmapi
ntpd wancfg_zaptel
ntpdate wanconfig
ntpdc wan_ec_client
ntp-keygen wanpipe_lxdialog
ntpq wanpipemon
ntptime wanpipemon_legacy
open_init_pty wan_plxup
openvpn wanrouter
ownership warnquota
packer wpbwm
pethtool wp_pppconfig
pifconfig xinetd
ping6 xpp_blink
pluginviewer xpp_sync
plymouth-set-default-theme xtalk_send
pm-hibernate yum-complete-transaction
pm-powersave yumdb
pm-suspend zdump
pm-suspend-hybrid zic
[[email protected] sbin]#

So far we have about 8 systems that show that same error message in the SSH screen Also, it appears that the systems need a update with the “Apply” button

Ok the first problem is that your amportal script is not getting replaced with the updated version. This can and will cause system outages among other things. Seems to work on other peoples systems?

Try running just:


and paste the output here.

Using username “root”.
[email protected] password:
Send automatic password
Last login: Fri Feb 19 14:27:41 2016 from


Unable to generate MOTD.
The /usr/sbin/fwconsole file is not accessible

You are likely to experience significant system issues.

[[email protected] ~]# /var/lib/asterisk/bin/freepbx_engine

-------------FreePBX Control Script-----------------------------------------------

Usage: amportal start|stop|restart|kill|chown

start: Starts Asterisk and Flash Operator Panel server if enabled
stop: Gracefully stops Asterisk
restart: Stop and Starts
kill: Kills Asterisk
chown: Sets appropriate permissions on files

[[email protected] ~]#

Not sure what you are asking “Seems to work on other peoples systems?” Many of th elater systems that we have checked are exhibiting the same errors.

When I say it’s working for other people I mean that you are the only person to have this issue with your systems.


Is completely wrong. It’s a very old version. This file should be getting replaced during framework upgrades.

Please find fwconsole first on your system:

locate fwconsole

Let me know if you find it.