Fwconsole ma refreshsignatures Framework corruption

After running fwconsole ma refreshsignatures due to framework being tampered with, my Freebpx crashes in a way that renders it completely down.

I’ve also attempted to update the framework module through the GUI, with a similar result, see below:

Can anyone help me get this Freepbx updated and running?

Additional information: when updating the Framework module through GUI, this is what I get.

Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications, cron_jobs…Done
Determined Asterisk version to be: 13.38.3
installing files to /var/www/html..error copying files:
‘cp -rf’ from src: ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/.’ to dst: ‘/var/www/html’…details follow
cp: cannot remove ‘/var/www/html/./admin/assets/fonts/opensans-bold-webfont.woff2’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/generator_config.txt’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/fontawesome-webfont.ttf’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/Schmooze.svg’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/opensans-regular-webfont.eot’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/glyphicons-halflings-regular.svg’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/opensans-regular-webfont.ttf’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/fontawesome-webfont.eot’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/fonts/glyphicons-halflings-regular.eot’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/js’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/assets/css’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/config.php’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/ajax.php’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/bootstrap.php’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./admin/index.php’: Input/output error
cp: cannot stat ‘/var/www/html/admin/modules/framework/amp_conf/htdocs/./index.php’: Input/output error
done, see errors below
installing files to /var/lib/asterisk/bin..error copying files:
‘cp -rf’ from src: ‘/var/www/html/admin/modules/framework/amp_conf/bin/*’ to dst: ‘/var/lib/asterisk/bin’…details follow
done, see errors below
installing files to /var/lib/asterisk/agi-bin..error copying files:
‘cp -rf’ from src: ‘/var/www/html/admin/modules/framework/amp_conf/agi-bin/*’ to dst: ‘/var/lib/asterisk/agi-bin’…details follow
done, see errors below

So you’re saying this specific FPBX instance was compromised by a bad actor? If it were me, I’d spin up a new instance and restore the most recent “good” backup before the existing instance has been confirmed to have IOC. Is this not an option in your situation?

Check your disk space ? “df -h” to see if your disk is full.

Hi - thank you for your input! The last known good backup is from 2021, though I did copy the complete virtual machine in March. I was able to recover that older version, and bring it up to date - I have yet to try a backup on that older version.

My current objective remains to try to figure out how to get my latest version “un compromised” - that’s because I have made quite a few changes to the system since March 2026.

It’s pretty wild that every time I update “Framework”, the file system gets corrupted and crashes. I’ve tripled the ram, and there’s plenty of space (I think!).

I’m considering downloading a CENTOS DVD ISO file to be able to for a repair of the file system once the update will corrupt the operating system, but I would have preferred to find what is causing the issue before it happens, rather than letting it happen and then trying to fix it.

Fortunately, I do have a checkpoint on the VM that allows me to roll back if needed (which I’ve been abusing today!)

My other concern is that the backup is not completing successfully. I would’ve loved to get mesylf onboard with version 17 and restore the backup…

Seems like my system has become unhealthy overtime, and clearly: my MSDOS skills are not sufficient to efficiently navigate Linux. I’ll take all the help this community can offer!

Booting using an ISO and running the following commmand:

xfs_repair /dev/mapper/SangomaVG-root

has found corruption and repaired it. Once the FS repaired, I was able to refreshsignatures without a full crash, and I was able to update Framework to the latest version, as well as all the other modules.

This issue is resolved… now on to the next issue: the backup not completing!

Thanks for your input, both of you!