Full distro cd i386 install problem


The install process freezes on freepbx-2.10.0-28-noarch
Steps to produce this :

  • configure eth0 ? YES

  • active on boot : YES

  • enable IPV4 support : YES

  • enable IPV6 support : NO

  • Choose manual address configuration : YES

  • enter ip address and netmask (ipAddr/

  • enter gateway

  • enter primary dns (I tried: my real public DNS, my ip gateway)

  • enter hostname (I tried : test, test.localdomain, test.localdomain.localhost)

The installation blocks at freepbx-2.10.0-28-noarch package.

With DHCP mode install, there is no problem.

Ok not sure but I will look into it. Are you entering valid network information. I think that RPM might have to reach out to FreePBX to install so that might be a problem but I think it will time out after awhile.

Yes I’m entering valid network information.
If I replace “test.localdomain” by “localhost.localdomain”, the installation works.
hostname=localhost; installation fails

The only way to get it work, is to enter “localhost.localdomain”

sounds like a apache issue. Will have to do more digging this week on that.

What happens if you enter a valid domain name in their that can be resolved.

I tried a valid domain name but no luck.
I keep going.

OK well I just tried www.schmoozecom.com as the domain and it worked fine

You set hostname to www.schmoozecom.com ?
It doesn’t work for me.

Just to clarify the freepbx rpm does not reach out to FreePBX.org for anything.


I was referring to a installall which would tell it to reach out to mirror.freepbx.org and pull all the updated modules on the mirror site not some type of phone home thing. Sorry I should of stated that better.

The only thing I can see that would be causing this issue is the install_amp that the RPM runs to install FreePBX seems to try and connect to localhost so if you are changing the normal localhost setting that Centos will setup than it would stall out.

I am doing another install using your exact steps as we speak

ok let me know if you want me to try something.

What happens if you use DHCP but change the hostname to something else?

Using DHCP and hostname set to “test”, installation finished without any problem.

OK so its not a hostname issue but something else. Wish I could reproduce this

you can’t reproduce the issue using my steps ?

New test.

configure eth0 ? I said NO

  • enter gateway = ipAddr
  • enter primary dns = public dns
  • enter hostname = test

Installation finished without any problem.

  • configure eth0 ? YES

  • enable IPV4 support : YES

  • enable IPV6 support : NO

  • Choose manual address configuration : YES

  • enter ip address and netmask (ipAddr/

  • enter gateway : NONE

  • enter primary dns : NONE

  • enter hostname : test

Installation finished without any problem.

OK I can reproduce it. It has nothing to do with hostname.

If you set static IP it hangs on the FreePBX Install. Not sure why yet and looking into it

OK after lots of screaming, and swearing I think it is resolved.

The issue is when setting up static at boot time during the install process it actually creates the eth0 and sets everything up but it never sets up a loopback. Since their is a DNS server defined the install_amp of the freepbx RPM tries to connect to localhost for mysql to setup the database. Their is no loopback but since you have a valid DNS and route/gateway anaconda sends the lookup for loopback out eth0 which fails to come back with a match so install_amp fails.

When using DHCP it does not actually setup the eth0 until after a reboot so their are not networks setup so install_amp installs fine.

Go figure. Anyways the install screen now ask you for network information just like the netinstall did so that the loopback can be setup. The new versions are pushing to the download area now for testing. Give it 15 mins or so to sync.

Oh yes ! You got it !
Let me try this tonight. I’ll give you feedback.