Ftp backup freepbx 15 fails with permission denied

Hi, after setting up Filestore wtih valid credentials for FTP server, running the backup using both Local and FTP, local is OK but FTP fails with permission denied.

ftp_fput(): 20200327-033149-1585294309- Permission denied
The backup email failure doesn’t show more than the line above.

From the FreePBX 15 server, cd /var/spool/asterisk/backups ftp to ftp server using the same credentials as in the Filestore config, login OK, run put filename.tar.gz and it uploads perfectly.

Question is, is the Filestore FTP user actually being used? It seems its not.

Hi @Hawkeye

Please make sure the path which you have given in the Filestore

can be accessed by your FTP user. If the FTP user does not have permission to that path then you will still get the permission denied error.

Also please try re-entering the password in the filestore as you mentioned you are able to login with the username and password manually.

1 Like

Ran backup using full /path/to/DIR and it worked. However, the backup file is a LOT smaller that previous backups (FPBX 13). Creating the backup, most things have been removed such as CDR’s and presumably that’s what is missing.

Is there a way to choose what is going to be backed up?

Hi @Hawkeye

In FreePBX 15 backup is designed in such a way that whenever you select a module to backup it will automatically backup all the files and contents with respect to that module.

One of the main reason for the size difference is webroot files in older version we used to backup the webroot files but in FreePBX 15 we are not backing up webroot files.

Inside the backup you can select which all modules you want to backup and the system will take care of all the required config files, userdata and database of that module.

Thank you.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.