FreePBX | Register | Issues | Wiki | Portal | Support

Fresh SNG7 install, DAHDI fails to load


#21

At least for me, when I had that issue, secure boot was not enabled, so I had to go back to distro 13 because of the DAHDI error.


(United States) #22

I don’t think the uefi would change the secure boot setting on it’s own, it used to work just fine.

When I try to run yum reinstall dahdi I get:
No Match for argument: dahdi.

I tried downloading it with wget but when I run the make command I receive this error:
make -C linux all
make[1]: Entering directory /root/dahdi-linux-complete-3.0.0+3.0.0/linux' make -C drivers/dahdi/firmware firmware-loaders make[2]: Entering directory/root/dahdi-linux-complete-3.0.0+3.0.0/linux/drivers/dahdi/firmware’
make[2]: Leaving directory /root/dahdi-linux-complete-3.0.0+3.0.0/linux/drivers/dahdi/firmware' You do not appear to have the sources for the 3.10.0-957.10.1.el7.x86_64 kernel installed. make[1]: *** [modules] Error 1 make[1]: Leaving directory/root/dahdi-linux-complete-3.0.0+3.0.0/linux’
make: *** [all] Error 2

uname -r returns:
3.10.0-957.10.1.el7.x86_64


#23

Run rpm -qa | grep dahdi and paste the output here


(United States) #24

dahdi-tools-2.11.1-2.sng7.x86_64
asterisk13-dahdi-13.26.0-1.sng7.x86_64
dahdi-linux-2.11.1-50.sng7.x86_64
kmod-dahdi-linux-2.11.1-52.sng7.x86_64
dahdi-firmware-3.0.0-1.sng7.noarch


(Andrew Nagy) #25

If you are going to build your own dahdi you need kernel sources which are a package in yum. If you’ve never built something before I strongly advise you to not build dahdi. Also you’re trying to build dahdi 3 when the distro uses 2. Please make sure you know what you are doing before proceeding.

Furthermore your yum reinstall command is not complete. You can do a yum list to figure out what to reinstall but plain “dahdi” is not valid.

I’ll add one comment here. All Sangoma hardware is tested with cards and this does work for many customers. You should try out Sangoma support if you have the time.


#26

I will let you know which version I have when I get back home. In the meantime, you can try uninstalling those packages with yum or rpm.


(United States) #27

First of all thank you for you reply, I am greatful for this wonderful open source product FreePBX and all that contribute to it.

I am a bit of a newbie when it comes to build installing packages with make, so I’ll take your advise on not doing it.

However I think you misunderstood my situation here, This is a FreePBX server in production that has been running smoothly until about a week ago when I started having issues with the time conditions module, among the things I’ve tried before figuring out that this module was at fault was a yum update, that seemed to have broken something and asterisk started freezing up randomly, naturally the first thing I did was a fwconsole restart but that gave me the dahdi error mentioned here, I actually don’t have any physical cards but I think dahdi should start anyway as it does on all my other systems, I don’t know if these 2 issues are related at all but they started at the same time and since I couldn’t see any major errors anywhere else I figured I should start here since the cause is most likely the same.

When I do a yum list | grep dahdi I get:
asterisk13-dahdi.x86_64 13.26.0-1.sng7 @sng-pkgs
dahdi-firmware.noarch 3.0.0-1.sng7 @anaconda/1805
dahdi-linux.x86_64 2.11.1-50.sng7 @anaconda/1805
dahdi-tools.x86_64 2.11.1-2.sng7 @anaconda/1805
kmod-dahdi-linux.x86_64 2.11.1-52.sng7 @sng-pkgs
asterisk11-dahdi.x86_64 11.25.3-1.sng7 sng-pkgs
asterisk14-dahdi.x86_64 14.7.8-1.sng7 sng-pkgs
asterisk15-dahdi.x86_64 15.5.0-1.sng7 sng-pkgs
asterisk16-dahdi.x86_64 16.3.0-1.sng7 sng-pkgs
dahdi-firmware-a4a.noarch a0017-1.3.sng sng-pkgs
dahdi-firmware-a4b.noarch d001e-1.3.sng sng-pkgs
dahdi-firmware-a8a.noarch 1d0017-1.3.sng sng-pkgs
dahdi-firmware-a8b.noarch 1f001e-1.3.sng sng-pkgs
dahdi-firmware-hx8.noarch 2.06-1.3.sng sng-pkgs
dahdi-firmware-oct6114-032.noarch 1.07.01-1.3.sng sng-pkgs
dahdi-firmware-oct6114-064.noarch 1.05.01-1.3.sng sng-pkgs
dahdi-firmware-oct6114-128.noarch 1.05.01-1.3.sng sng-pkgs
dahdi-firmware-oct6114-256.noarch 1.05.01-1.3.sng sng-pkgs
dahdi-firmware-oct6126-128.noarch 01.07.04-1.3.sng sng-pkgs
dahdi-firmware-tc400m.noarch MR6.12-1.3.sng sng-pkgs
dahdi-firmware-te133.noarch 780019-1.3.sng sng-pkgs
dahdi-firmware-te134.noarch 780017-1.3.sng sng-pkgs
dahdi-firmware-te435.noarch e0019-1.3.sng sng-pkgs
dahdi-firmware-te436.noarch 10017-1.3.sng sng-pkgs
dahdi-firmware-te820.noarch 1.76-1.3.sng sng-pkgs
dahdi-firmware-vpmoct032.noarch 1.12.0-1.3.sng sng-pkgs
dahdi-linux-devel.x86_64 2.11.1-50.sng7 sng-pkgs
dahdi-tools-doc.x86_64 2.11.1-2.sng7 sng-pkgs

Which is the one I have to reinstall? One of them is listed with version 3.0.0-1.sng7 is that an issue?

P.s. Iv’e since spun up a cloud server on aws and restored the config there until I figure out what’s wrong with this system or reinstall it.


(United States) #28

Oh and also thanks to you @arielgrin your help is highly appreciated.


(Andrew Nagy) #29

Answer for your issues ^ (thread is also stickied)

You don’t have dahdi. You shouldnt care about dahdi issues.

fwconsole ma disable dahdiconfig


(United States) #30

Wow! are telling me that I wasted all these hours by just not following the news! damn


(United States) #31

I disabled Dahdi but actually just checked with a friend of mine and he also tried to do a yum update and also got some errors errors about dahdi not being compatible with the kernel, so this might be a separate issue you might wanna look in to, I honestly don’t care that much about dahdi I just figured I should let you know.


#32

Thanks for the info. Anyway I don’t have that issue, I had it when originally posted about it. I just updated my FreePBX 14 yesterday with yum, which updated more than 250 packages, dahdi among them, and I didn’t have any issues after the upgrade. But yes, it seems to be an issue related to kernel mismatch, but can’t say for sure.


(Andrew Nagy) #33

After yum upgrade make sure to restart asterisk otherwise you’re using old code!


#34

I made sure to perform a complete reboot to be sure and I didn’t get any issues.


(system) closed #35

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.