Fresh install FreePBX - Asterisk 13 - can't activate

I have completed a fresh install of FreePBX 64bit / Asterisk 13 that I just downloaded the ISO today. Seems that the initial updates completed. I rebooted a couple times but cannot get System Admin - Activation to complete. When I press the ‘Activate’ button I get a red ‘Error’ box in the upper right corner that goes away quickly. One time I managed to get to a screen that let me type in my contact information but when I submitted this it went back to the System Activation page with the message that I need to activate. I have not been able to get to that point again.

I don’t really know what to do at this point as this is useless until I get past this point.

Nathan

No problems that I’m aware of, but I’ll look into it.

I tried several more times since posting. I managed to get the message asking is I want to activate now but then it went back to the same page again. I’ve given up for tonight as this has exhausted me.

Sorry, seems to work for me. If it’s still not working in the morning, you can send me a private message with some more details and I’ll look into it further.

Make sure you can resolve dns. This has been a know issue I have seen over the forum and had the issue my self. Go to the CLI and ping www.yahoo.com and make sure it resolves.

I can telnet to the box and nslookup and ping are responding with valid results from the command line.

One thing I’m looking into, when I first started up the UI, the firewall message came up and I aborted the starting of the firewall as I don’t want yet another firewall to deal with. However I haven’t found how to turn it back on as you can’t seem to do that from the command line. The message indicates it can only be started from the web UI.

Would this be impacting the activation if the rest of the networking seems to be working ok?

Nathan

I found the firewall controls, enabled it and raw the wizard to setup the initial network range. This has no effect on the activation problem. I still get the red ‘error’ box that appears briefly in the upper right corner.

I have tried IE (in place of Firefox) as my browser and this had no (good) effect. With IE the I don’t even get the error box, just a blinking cursor in the menu line. Seems that something if fundamentally broken. Seem foolish to try another clean install but this is silly to be wasting so much time on something that doesn’t seem to have any way around.

Is there a way to bypass the activation tool and get an activation code manually from the Sangoma portal and enter this into a config file? Even Microsoft has two or three different ways to activate their software.

I have now tried a complete fresh re-install of 64bit and have the exact same results. This time I went through the firewall setup from the start without aborting. Nslookup and ping responding properly.

I have done a fresh install of FreePBX 12 64bit / Asterisk 11 and have the behavior when trying to activate where it just seems to give me the same page indicating I need to activate. Nslookup and ping are working on this installation also.

Does anybody have any ideas on how to troubleshoot or get around this?

Do you have the latest ver of sysadmin and do you have ivp6 enables when you installed FREEPBX

I’m still trying with FreePBX 12 / Asterisk 11. It seems to be updated to the latest. Is there a way to tell? What would I look for?

ipv6 was set to automatic during the initial installation.

The current IP address is as follows:
[[email protected] ~]# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 10:60:4b:6a:e0:12 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.8/24 brd 192.168.1.255 scope global eth0
inet6 fe80::1260:4bff:fe6a:e012/64 scope link
valid_lft forever preferred_lft forever

Do I need a different configuration for activation?

Go to modules admin and check for updates for standard and commercial.

I have had this issue before but not being on the Internet was my issue. I also remember seeming a post about ivp6 being enabled.

I found System Admin module is 12.0.45.6 in the module panel on FreePBX 12 / Asterisk 11.

All modules are reported as up to date and enabled except the FreePBX ARI framework which is indicated as disabled. Is that needed?

I have System Admin module 12.0.45.6 also on one of my boxes I run. So you have the newest verison.

Try to uninstall sysadmin and reinstall

amportal a ma uninstall sysadmin
amportal a ma install sysadmin

amportal chown

amportal a r

One more thing try to use chrome to activate and see if that works.