Fresh FreePBX15 install - one way audio, worked with prev version before


(Bob) #1

Hello

If someone could help.
I had a working FreePBX13 at home, everything worked fine…
I just installed version 15, disabled iptables, fail2ban (sitting behind the physical firewall).

Straight install… Created IVR, recorded prompts… When calling from my cell - can’t make a selection. If I don’t use IVR and go to deskphone - one way audio…

Just like with ver13, I am using channel SIP, not PJSIP. Tried with and without nat=force_rport,auto_comedia in trunk config - no difference.

Put old FreePBX13 - works…

So anyone has a clue?


#2

You need to correctly set your networks on the SIP settings page under the Advanced settings menu.


(Bob) #3

Thanks… Advanced setting pretty much were the same between ver 13 and 15 except a couple of things like send rpid=pai

You got me thinking though… under Asterisk settings I noticed that SIP channel external IP somehow is set to my public static on ver 15… on version 13 - it is the internal IP address.
Interesting enough - mouse over that field suggests: “External Static IP or FQDN as seen on the WAN side of the router. …” but if I use external static on v15 - does not work (one way audio). Do it with internal IP - and it started to work!

This is weird… but… at least found the issue with your help. Thanks!!!


#4

Your experience is strange. Normally, in Asterisk SIP Settings on the General tab, you set your External Address and Local Networks. This data is for both pjsip and chan_sip. On the chan_sip tab, you can override the external address, but that is only required in unusual circumstances and is normally left blank.

The purpose of these settings is for Asterisk to supply its external address in SDP (telling the remote server or device where to send audio) when the remote address is not in the ranges set in Local Networks.

What may be happening in your case is one of:

  1. The external address on the General tab is incorrect.
  2. Your router/firewall does not have the RTP port range forwarded to the internal address of the PBX.
  3. Your router/firewall has a SIP ALG enabled that is corrupting the traffic.
  4. Your router/firewall is not preserving the source port number for outgoing RTP.

Then, when you put the internal IP as the external address, the trunking provider sees your system as behind NAT and does their own NAT traversal logic (including sending RTP back to the address and port that your RTP came from), which works around the problem. IMO this is not a good long term solution because it won’t work with external extensions, unless they can simulate being on a public IP, and it won’t work with trunking providers that don’t handle NAT traversal.


(Bob) #5

Thanks for the good points…
As I mentioned originally - FreePBX13 on the same internal IP (fresh install), same firewall - no issue
FreePBX15 - issues
Firewall stayed the same… I also forgot to mention another interesting thing - when trunk was configured - I was seeing registration timeout messages on the asterisk console… However - rebooted the system - it registered just fine (I guess I could have just restarted FreePBX service)…

To your point

  1. External address on the general tab was set correctly (correct public IP)
    2 -4 it is the same router that works fine with Freepbx v13 or if I simply take a Aasta phone and register directly with a provider…

I guess I need to double check SIP ALG… It is a Fortigate60f firewall and I believe it does have it enabled by default…

Thank you very much for good pointers! I will look into that and if I find something interesting - I will post back here.


(system) closed #6

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.