FreePBX® 2.3.0beta2 With Lots of Great Enhancements

Hello everyone and back again with more exciting news. We’ve been working hard to finsh off all the great work that the team has done leading up to and during our FreePBX-athon last week (this one also). We think you are going like the new addtions we have added to this Beta2 release. Below are some highlights but the best way to find out what it is all about is to go upgrade your Beta1 systems through the Online Upgrade system, or go grab the new tarball and go through the same install_amp that you always have used!

Read the full article here: FreePBX® 2.3.0beta2 With Lots of Great Enhancements

Not that anything was bad to begin with, but things are shaping up nicely.

This is very good stuff. A little issue, on the FreePBX System Status Index Page I am getting a few errors

Notice Undefined index sip_online in /var/www/html/admin/modules/dashboard/class.astinfo.php on line 64

Notice Undefined index sip_offline in /var/www/html/admin/modules/dashboard/class.astinfo.php on line 65

Notice Undefined index sip_total in /var/www/html/admin/modules/dashboard/class.astinfo.php on line 66

Notice Undefined index sip_online in /var/www/html/admin/modules/dashboard/page.index.php on line 224

Notice Undefined index sip_total in /var/www/html/admin/modules/dashboard/page.index.php on line 224

Excellent. I hate to go gaga over eye candy, but this blows away the trixbox “status” page.

well there’s clearly eye candy there :lol: but at the same time, we really hope that we have selected an appropriate cross section of information to show a very valuable overview of the system. The one thing that is missing (and we’ll get it in) is probably the average queue length of each queue that is configured, or maybe an aggregate of all the queues…

I think the refresh rate is nice. Is a config edit like utility ging to be available?

what do you mean by a config edit utility?

An interface to .conf files

I thought that was what an editor was, especially one like vim that can be configured to understand conf file syntax…

Hey, I never claimed to be the brightest bulb in the display. I get it, just continue to use VIM or nano, etc…

On another note, are there any good guides on building a LAMP with Asterisk and FreePBX only?

I’d like to experiment with SuSE and Ubuntu.


Not to be old fashioned - but I kind of liked the old style better - any chance there will be an option to restore the old theme

  • it just seemed to flow quicker - for instance when I Apply Changes - I used to be able to quickly hit the space bar to accept - now I have to move my lazy mouse over and click, when I administer a change to 10-20 systems a day - this adds a bit of unwanted time.

The new look is very invigorating, i like the seperate tabs in their own spot for setup/tools, and some of the other stuff, but in other cases simple is better - just feel like its been tweeked to the core, and then tweeked on some more, tad bit of bloat. The old logo seems more appealing too.

no bad intentions to the designer, its definitely a step up, a very good job, but except for a couple small items it seemed just as sufficient before.

forgot - system memory usage seems inversed.

I got the following error while upgrading from freepbx:

Downloading framework 2377650 of 2377650 (100%)
Checking for upgrades…
Warning: usort(): Invalid comparison function. in /var/www/html/admin/modules/framework/libfreepbx.install.php on line 42

Fatal error: Call to undefined function: version_compare_freepbx() in /var/www/html/admin/modules/framework/libfreepbx.install.php on line 48

After this, I get this on all pages:

SELECT * FROM notifications ORDER BY level, module [nativecode=1146 ** Table ‘asterisk.notifications’ doesn’t exist]

The only way I have to fix it is to use RPM, un-install freepbx, re-install it, and reload my backup.

for starters, you do not need to uninstall everything. You could just pull the tarball and when you install, do a --force-versions 2.2.2.

As far as the version_compare_freepbx() error, looks like that may be a bug from having upgraded from an earlier version where version_compare_freepbx() was not included in Thanks - will look into addressing that in the next framework upgrade.

The CLI update v1.1.1 may have an issue

Parse error parse error, unexpected ‘=’ in /var/www/html/admin/modules/asterisk-cli/page.cli.php on line 38

I tried “amportal restart” and restarted httpd and msqld.


EDIT v1.1.2 fixed it. THANKS!

I am not sure what this means, but last couple of times, I had to manually check for updates. They were not showing in the status area.

my bad - too many late night fixes. I over compensated for the previous checking for updates hourly mistake. Anyhow - I think it is correct this time, there should be a new framework update ready (within 10 minutes) that fixe that and another fix.

I just updated to the latest core and something borked
Parse error parse error, unexpected ‘;’ in /var/www/html/admin/modules/queues/ on line 277

it was the queues module actually - should be fixed, a typo slipped in untested by accident.

So it was… Still, I had to rename to oldfun… to get the Module Admin to come back up so I could update.