FreePBX & yum woes

Although I’m a software developer, my career has always been inside a Windows environment, and I’m very new to Linux.

Despite that… I’ve spent the last 5 days, 18 hours a day, sucking up everything I can on Linux and Elastix and FreePBX, and I’ve got a pretty good configuration going so far.

Knowing only enough to be dangerous, I think I’ve recently made a fatal mistake…

Following a tutorial on how to install webmin, I ran an update with yum.

After that (and subsequent reboots) … The PBX runs great, just as it did prior to the update … however, the web UI no longer functions properly.

If I use the IP address (not the FQDN, which no longer works as of the update) I can see all Elastix UI’s (including OpenFire, etc). Despite that, FreePBX is not working, not the embedded or un-embedded version.

So I’ve got two strange issues resulting from the yum update: the FQDN (url) no longer works, although the name-resolution works fine; and, the FreePBX Web UI no longer works. Meanwhile the PBX runs fine.

I’m able to stop/start/restart httpd and amportal without any problem. Also… I don’t get 404 errors; the HTTP responses are being delivered. They are simply being delivered empty.

After spending 4 hours trying to find a solution, I finally tried a yum re-install on httpd. That didn’t fix it. I did’t want to try re-installing anything else, until I posted here and let the experts chime-in, before I make things worse.

Looking at the yum packages, it appears I’m running:


I could include the entire list, but I thought I’d try to make it simpler by including the packages that might be related. If you’d like me to include more, I’ll get them up for you ASAP.

Thank you in advance for any suggestions!

Save yourself a lot of grief from installing from scratch and install a precompiled distribution like PBX in a Flash or Orgasmatron. You will also have better support as the configuration will be standardized and the support forums will know exactly how your configuration should be.

Yes, I had originally installed FreePBX (the reason for posting in the FreePBX forum) as was upgrading the entire system (not just the Asterisk/FreePBX portion) with yum, which caused the issue.

It turned out to be a problem with Pear. Once I un-installed and re-installed Pear, everything worked out.