FreePBX yum update fails with Error: Multilib version problems found


(Hawk McDuck) #1

FreePBX 14.0.13.28 / Asterisk 13.32.0

When running yum update, I see the following error:

=============================
$ sudo yum update
Loaded plugins: fastestmirror, langpacks, versionlock
Loading mirror speeds from cached hostfile

  • elrepo: muug.ca

  • nux-dextop: li.nux.ro
    Resolving Dependencies
    –> Running transaction check
    —> Package ghostscript.x86_64 0:9.07-31.el7_6.11 will be updated
    –> Processing Dependency: ghostscript = 9.07-31.el7_6.11 for package: ghostscript-cups-9.07-31.el7_6.11.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: 2:gimp-2.8.22-1.el7.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: ghostscript-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: ImageMagick-6.7.8.9-16.el7_6.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: libspectre-0.2.8-1.el7.x86_64
    –> Processing Dependency: libijs-0.35.so()(64bit) for package: gutenprint-5.2.9-18.el7.x86_64
    –> Processing Dependency: libijs-0.35.so()(64bit) for package: cups-filters-1.0.35-22.el7.x86_64
    —> Package ghostscript.x86_64 0:9.25-2.el7_7.3 will be an update
    —> Package google-chrome-stable.x86_64 0:81.0.4044.122-1 will be updated
    —> Package google-chrome-stable.x86_64 0:81.0.4044.129-1 will be an update
    —> Package urw-base35-fonts.noarch 0:20170801-10.el7 will be obsoleting
    –> Processing Dependency: urw-base35-fonts-common = 20170801-10.el7 for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-z003-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-standard-symbols-ps-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-p052-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-nimbus-sans-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-nimbus-roman-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-nimbus-mono-ps-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-gothic-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-d050000l-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-c059-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-bookman-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    —> Package urw-fonts.noarch 0:2.4-16.el7 will be obsoleted
    –> Running transaction check
    —> Package ghostscript.i686 0:9.07-31.el7_6.11 will be installed
    –> Processing Dependency: libz.so.1 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libtiff.so.5(LIBTIFF_4.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libtiff.so.5 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.3.2) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.2) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpng15.so.15(PNG15_0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpng15.so.15 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libm.so.6(GLIBC_2.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libm.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: liblcms2.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libkrb5.so.3 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libk5crypto.so.3 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libjpeg.so.62 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libgssapi_krb5.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libfreetype.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libfontconfig.so.1 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libdl.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcupsimage.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcups.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcrypt.so.1 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcom_err.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libc.so.6(GLIBC_2.11) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libXt.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libXext.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libX11.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libSM.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libICE.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    —> Package ghostscript.x86_64 0:9.07-31.el7_6.11 will be updated
    —> Package libgs.x86_64 0:9.25-2.el7_7.3 will be installed
    –> Processing Dependency: adobe-mappings-pdf for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: adobe-mappings-cmap-deprecated for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: adobe-mappings-cmap for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: libpaper.so.1()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: libopenjp2.so.7()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
    —> Package urw-base35-bookman-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-c059-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-d050000l-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-fonts-common.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-gothic-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-nimbus-mono-ps-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-nimbus-roman-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-nimbus-sans-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-p052-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-standard-symbols-ps-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-z003-fonts.noarch 0:20170801-10.el7 will be installed
    –> Running transaction check
    —> Package adobe-mappings-cmap.noarch 0:20171205-3.el7 will be installed
    —> Package adobe-mappings-cmap-deprecated.noarch 0:20171205-3.el7 will be installed
    —> Package adobe-mappings-pdf.noarch 0:20180407-1.el7 will be installed
    —> Package cups-libs.i686 1:1.6.3-35.el7 will be installed
    –> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libstdc++.so.6 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libssl.so.10(libssl.so.10) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libssl.so.10 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libselinux.so.1 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libgcc_s.so.1 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libcrypto.so.10(libcrypto.so.10) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libcrypto.so.10 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libavahi-common.so.3 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libavahi-client.so.3 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libaudit.so.1 for package: 1:cups-libs-1.6.3-35.el7.i686
    —> Package fontconfig.i686 0:2.13.0-4.3.el7 will be installed
    –> Processing Dependency: libuuid.so.1(UUID_1.0) for package: fontconfig-2.13.0-4.3.el7.i686
    –> Processing Dependency: libuuid.so.1 for package: fontconfig-2.13.0-4.3.el7.i686
    –> Processing Dependency: libexpat.so.1 for package: fontconfig-2.13.0-4.3.el7.i686
    —> Package freetype.i686 0:2.8-12.el7_6.1 will be installed
    –> Processing Dependency: libbz2.so.1 for package: freetype-2.8-12.el7_6.1.i686
    —> Package glibc.i686 0:2.17-260.el7_6.6 will be installed
    –> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-260.el7_6.6.i686
    –> Processing Dependency: libfreebl3.so for package: glibc-2.17-260.el7_6.6.i686
    —> Package krb5-libs.i686 0:1.15.1-37.el7_6 will be installed
    –> Processing Dependency: libverto.so.1 for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.5) for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.0) for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.15.1-37.el7_6.i686
    —> Package lcms2.i686 0:2.6-3.el7 will be installed
    —> Package libICE.i686 0:1.0.9-9.el7 will be installed
    —> Package libSM.i686 0:1.2.2-2.el7 will be installed
    —> Package libX11.i686 0:1.6.5-2.el7 will be installed
    –> Processing Dependency: libxcb.so.1 for package: libX11-1.6.5-2.el7.i686
    —> Package libXext.i686 0:1.3.3-3.el7 will be installed
    —> Package libXt.i686 0:1.1.5-3.el7 will be installed
    —> Package libcom_err.i686 0:1.42.9-13.el7 will be installed
    —> Package libjpeg-turbo.i686 0:1.2.90-6.el7 will be installed
    —> Package libpaper.x86_64 0:1.1.24-8.el7 will be installed
    —> Package libpng.i686 2:1.5.13-7.el7_2 will be installed
    —> Package libtiff.i686 0:4.0.3-27.el7_3 will be installed
    –> Processing Dependency: libjbig.so.2.0 for package: libtiff-4.0.3-27.el7_3.i686
    —> Package openjpeg2.x86_64 0:2.3.1-1.el7 will be installed
    —> Package zlib.i686 0:1.2.7-18.el7 will be installed
    –> Running transaction check
    —> Package audit-libs.i686 0:2.8.4-4.el7 will be installed
    –> Processing Dependency: libcap-ng.so.0 for package: audit-libs-2.8.4-4.el7.i686
    —> Package avahi-libs.i686 0:0.6.31-19.el7 will be installed
    –> Processing Dependency: libdbus-1.so.3 for package: avahi-libs-0.6.31-19.el7.i686
    —> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
    —> Package expat.i686 0:2.1.0-10.el7_3 will be installed
    —> Package jbigkit-libs.i686 0:2.0-11.el7 will be installed
    —> Package keyutils-libs.i686 0:1.5.8-3.el7 will be installed
    —> Package libgcc.i686 0:4.8.5-36.el7_6.2 will be installed
    —> Package libselinux.i686 0:2.5-14.1.el7 will be installed
    –> Processing Dependency: libsepol(x86-32) >= 2.5-10 for package: libselinux-2.5-14.1.el7.i686
    –> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-14.1.el7.i686
    –> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-14.1.el7.i686
    –> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-14.1.el7.i686
    —> Package libstdc++.i686 0:4.8.5-36.el7_6.2 will be installed
    —> Package libuuid.i686 0:2.23.2-59.el7_6.1 will be installed
    —> Package libverto.i686 0:0.2.5-4.el7 will be installed
    —> Package libxcb.i686 0:1.13-1.el7 will be installed
    –> Processing Dependency: libXau.so.6 for package: libxcb-1.13-1.el7.i686
    —> Package nss-softokn-freebl.i686 0:3.36.0-5.el7_5 will be installed
    —> Package openssl-libs.i686 1:1.0.2k-16.el7_6.1 will be installed
    –> Running transaction check
    —> Package dbus-libs.i686 1:1.10.24-13.el7_6 will be installed
    –> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209) for package: 1:dbus-libs-1.10.24-13.el7_6.i686
    –> Processing Dependency: libsystemd.so.0 for package: 1:dbus-libs-1.10.24-13.el7_6.i686
    —> Package libXau.i686 0:1.0.8-2.1.el7 will be installed
    —> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
    —> Package libsepol.i686 0:2.5-10.el7 will be installed
    —> Package pcre.i686 0:8.32-17.el7 will be installed
    –> Running transaction check
    —> Package systemd-libs.i686 0:219-62.el7_6.7 will be installed
    –> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: liblzma.so.5(XZ_5.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: liblzma.so.5 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: liblz4.so.1 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libgpg-error.so.0 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libgcrypt.so.11 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libdw.so.1 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libcap.so.2 for package: systemd-libs-219-62.el7_6.7.i686
    –> Running transaction check
    —> Package elfutils-libs.i686 0:0.172-2.el7 will be installed
    –> Processing Dependency: elfutils-libelf(x86-32) = 0.172-2.el7 for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.7) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.6) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.5) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.4) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.3) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.1.1) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.0) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1 for package: elfutils-libs-0.172-2.el7.i686
    —> Package libcap.i686 0:2.22-9.el7 will be installed
    –> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-9.el7.i686
    –> Processing Dependency: libattr.so.1 for package: libcap-2.22-9.el7.i686
    —> Package libgcrypt.i686 0:1.5.3-14.el7 will be installed
    —> Package libgpg-error.i686 0:1.12-3.el7 will be installed
    —> Package lz4.i686 0:1.7.5-2.el7 will be installed
    —> Package pam.i686 0:1.1.8-22.el7 will be installed
    –> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-22.el7.i686
    –> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-22.el7.i686
    —> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
    –> Running transaction check
    —> Package cracklib.i686 0:2.9.0-11.el7 will be installed
    —> Package elfutils-libelf.i686 0:0.172-2.el7 will be installed
    —> Package libattr.i686 0:2.4.46-13.el7 will be installed
    —> Package libdb.i686 0:5.3.21-24.el7 will be installed
    –> Finished Dependency Resolution
    Error: Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem. Eg.:

      1. You have an upgrade for ghostscript which is missing some
         dependency that another package requires. Yum is trying to
         solve this by installing an older version of ghostscript of the
         different architecture. If you exclude the bad architecture
         yum will tell you what the root cause is (which package
         requires what). You can try redoing the upgrade with
         --exclude ghostscript.otherarch ... this should give you an error
         message showing the root cause of the problem.
    
      2. You have multiple architectures of ghostscript installed, but
         yum can only see an upgrade for one of those architectures.
         If you don't want/need both architectures anymore then you
         can remove the one with the missing update and everything
         will work.
    
      3. You have duplicate versions of ghostscript installed already.
         You can use "yum check" to get yum show these errors.
    
    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).
    
    Protected multilib versions: ghostscript-9.07-31.el7_6.11.i686 != ghostscript-9.25-2.el7_7.3.x86_64
    

$ sudo yum list installed | grep -i ghost
ghostscript.x86_64 9.07-31.el7_6.11 @sng-updates/7.5
ghostscript-cups.x86_64 9.07-31.el7_6.11 @sng-updates
ghostscript-fonts.noarch 5.50-32.el7 @anaconda/1712
$

=========================
I’m not sure how to progress this further. Anyone have suggestions?


(Shahin Nazir) #2

Hi @sgseidel

Are you using different repository ? I think you have issue on your Repository list.

yum repolist
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
repo id repo name status
sng-base/7/x86_64 Sangoma-7 - Base 10,019
sng-epel/7/x86_64 Sangoma-7 - Sangoma Epel mirror 16,253
sng-extras/7/x86_64 Sangoma-7 - Extras 419
sng-pkgs/7/x86_64 Sangoma-7 - Sangoma Open Source Packages 1,286
sng-updates/7/x86_64 Sangoma-7 - Updates 2,235
repolist: 30,212


yum -v repolist
Loading “fastestmirror” plugin
Loading “versionlock” plugin
Config time: 0.028
Yum version: 3.4.3
Loading mirror speeds from cached hostfile
Setting up Package Sacks
Reading version lock configuration
pkgsack time: 0.037
Repo-id : sng-base/7/x86_64
Repo-name : Sangoma-7 - Base
Repo-revision: 1543161601
Repo-updated : Sun Nov 25 16:00:34 2018
Repo-pkgs : 10,019
Repo-size : 9.4 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=os&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/os/7.6/os/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 11:48:55 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo
Repo-id : sng-epel/7/x86_64
Repo-name : Sangoma-7 - Sangoma Epel mirror
Repo-revision: 1563341482
Repo-updated : Wed Jul 17 06:38:05 2019
Repo-pkgs : 16,253
Repo-size : 29 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=epel&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/sng7/epel/
Repo-expire : 21,600 second(s) (last: Mon May 4 11:48:55 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo
Repo-id : sng-extras/7/x86_64
Repo-name : Sangoma-7 - Extras
Repo-revision: 1560955949
Repo-updated : Wed Jun 19 15:55:32 2019
Repo-pkgs : 419
Repo-size : 588 M
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=extras&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/os/7.6/extras/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 11:48:56 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo
Repo-id : sng-pkgs/7/x86_64
Repo-name : Sangoma-7 - Sangoma Open Source Packages
Repo-revision: 1586868364
Repo-updated : Tue Apr 14 13:46:23 2020
Repo-pkgs : 1,285
Repo-size : 3.2 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=sng7&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/sng7/sng7/
Repo-expire : 21,600 second(s) (last: Mon May 4 11:48:56 2020)
Filter : read-only:present
Repo-excluded: 1
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo
Repo-id : sng-updates/7/x86_64
Repo-name : Sangoma-7 - Updates
Repo-revision: 1562945039
Repo-updated : Fri Jul 12 16:35:51 2019
Repo-pkgs : 2,235
Repo-size : 11 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=updates&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/os/7.6/updates/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 11:48:56 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo
repolist: 30,211


yum clean all



(Hawk McDuck) #3

@snazir Thanks for your reply.

You said:

Are you using different repository ? I think you have issue on your Repository list.

I’m not sure I understand, could you be more specific please? As far as I’m aware I haven’t done anything out of the ordinary when updating FreePBX. I have installed additional packages, such as the gnome-desktop, FOP2, timeshift, synergy, gimp, wireshark, webmin, Google Chrome, zoiper, gparted, but these have not caused an issue previously when updating FreePBX using yum over the past months.

When I run yum clean all, here is the output:

$ sudo yum clean all
[sudo] password for stewart:
Loaded plugins: fastestmirror, langpacks, versionlock
Cleaning repos: elrepo google-chrome nux-dextop sng-base sng-epel sng-extras sng-pkgs sng-updates sng7-debuginfo sng7-testing virtualbox
Cleaning up list of fastest mirrors
Other repos take up 989 M of disk space (use --verbose for details)
[stewart@freepbx ~]$ sudo yum update
Loaded plugins: fastestmirror, langpacks, versionlock
Determining fastest mirrors

  • elrepo: repos.lax-noc.com

  • nux-dextop: mirror.li.nux.ro
    elrepo | 2.9 kB 00:00:00
    google-chrome | 1.3 kB 00:00:00
    nux-dextop | 2.9 kB 00:00:00
    sng-base | 3.6 kB 00:00:00
    sng-epel | 2.9 kB 00:00:00
    sng-extras | 3.4 kB 00:00:00
    sng-pkgs | 3.4 kB 00:00:00
    sng-updates | 3.4 kB 00:00:00
    sng7-debuginfo | 3.4 kB 00:00:00
    sng7-testing | 2.9 kB 00:00:00
    virtualbox/7/x86_64/signature | 181 B 00:00:00
    virtualbox/7/x86_64/signature | 2.9 kB 00:00:00 !!!
    (1/12): google-chrome/primary | 1.9 kB 00:00:00
    (2/12): sng-base/7/x86_64/group_gz | 166 kB 00:00:00
    (3/12): sng-extras/7/x86_64/primary_db | 205 kB 00:00:00
    (4/12): sng-pkgs/7/x86_64/primary_db | 703 kB 00:00:01
    (5/12): nux-dextop/x86_64/primary_db | 1.8 MB 00:00:02
    (6/12): sng7-debuginfo/primary_db | 31 kB 00:00:00
    (7/12): sng-epel/7/x86_64/primary_db | 7.5 MB 00:00:05
    (8/12): elrepo/primary_db | 480 kB 00:00:06
    (9/12): virtualbox/7/x86_64/primary_db | 156 kB 00:00:00
    (10/12): sng7-testing/primary_db | 1.3 MB 00:00:05
    (11/12): sng-base/7/x86_64/primary_db | 6.0 MB 00:00:09
    (12/12): sng-updates/7/x86_64/primary_db | 6.5 MB 00:00:08
    google-chrome 3/3
    Resolving Dependencies
    –> Running transaction check
    —> Package ghostscript.x86_64 0:9.07-31.el7_6.11 will be updated
    –> Processing Dependency: ghostscript = 9.07-31.el7_6.11 for package: ghostscript-cups-9.07-31.el7_6.11.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: 2:gimp-2.8.22-1.el7.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: ghostscript-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: ImageMagick-6.7.8.9-16.el7_6.x86_64
    –> Processing Dependency: libgs.so.9()(64bit) for package: libspectre-0.2.8-1.el7.x86_64
    –> Processing Dependency: libijs-0.35.so()(64bit) for package: gutenprint-5.2.9-18.el7.x86_64
    –> Processing Dependency: libijs-0.35.so()(64bit) for package: cups-filters-1.0.35-22.el7.x86_64
    —> Package ghostscript.x86_64 0:9.25-2.el7_7.3 will be an update
    —> Package google-chrome-stable.x86_64 0:81.0.4044.122-1 will be updated
    —> Package google-chrome-stable.x86_64 0:81.0.4044.129-1 will be an update
    —> Package urw-base35-fonts.noarch 0:20170801-10.el7 will be obsoleting
    –> Processing Dependency: urw-base35-fonts-common = 20170801-10.el7 for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-z003-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-standard-symbols-ps-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-p052-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-nimbus-sans-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-nimbus-roman-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-nimbus-mono-ps-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-gothic-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-d050000l-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-c059-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    –> Processing Dependency: urw-base35-bookman-fonts for package: urw-base35-fonts-20170801-10.el7.noarch
    —> Package urw-fonts.noarch 0:2.4-16.el7 will be obsoleted
    –> Running transaction check
    —> Package ghostscript.i686 0:9.07-31.el7_6.11 will be installed
    –> Processing Dependency: libz.so.1 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libtiff.so.5(LIBTIFF_4.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libtiff.so.5 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.3.2) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.2) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpthread.so.0 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpng15.so.15(PNG15_0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libpng15.so.15 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libm.so.6(GLIBC_2.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libm.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: liblcms2.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libkrb5.so.3 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libk5crypto.so.3 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libjpeg.so.62 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libgssapi_krb5.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libfreetype.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libfontconfig.so.1 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libdl.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcupsimage.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcups.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcrypt.so.1 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libcom_err.so.2 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libc.so.6(GLIBC_2.11) for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libXt.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libXext.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libX11.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libSM.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    –> Processing Dependency: libICE.so.6 for package: ghostscript-9.07-31.el7_6.11.i686
    —> Package ghostscript.x86_64 0:9.07-31.el7_6.11 will be updated
    —> Package libgs.x86_64 0:9.25-2.el7_7.3 will be installed
    –> Processing Dependency: adobe-mappings-pdf for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: adobe-mappings-cmap-deprecated for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: adobe-mappings-cmap for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: libpaper.so.1()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
    –> Processing Dependency: libopenjp2.so.7()(64bit) for package: libgs-9.25-2.el7_7.3.x86_64
    —> Package urw-base35-bookman-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-c059-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-d050000l-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-fonts-common.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-gothic-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-nimbus-mono-ps-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-nimbus-roman-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-nimbus-sans-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-p052-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-standard-symbols-ps-fonts.noarch 0:20170801-10.el7 will be installed
    —> Package urw-base35-z003-fonts.noarch 0:20170801-10.el7 will be installed
    –> Running transaction check
    —> Package adobe-mappings-cmap.noarch 0:20171205-3.el7 will be installed
    —> Package adobe-mappings-cmap-deprecated.noarch 0:20171205-3.el7 will be installed
    —> Package adobe-mappings-pdf.noarch 0:20180407-1.el7 will be installed
    —> Package cups-libs.i686 1:1.6.3-35.el7 will be installed
    –> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libstdc++.so.6 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libssl.so.10(libssl.so.10) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libssl.so.10 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libselinux.so.1 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libgcc_s.so.1 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libcrypto.so.10(libcrypto.so.10) for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libcrypto.so.10 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libavahi-common.so.3 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libavahi-client.so.3 for package: 1:cups-libs-1.6.3-35.el7.i686
    –> Processing Dependency: libaudit.so.1 for package: 1:cups-libs-1.6.3-35.el7.i686
    —> Package fontconfig.i686 0:2.13.0-4.3.el7 will be installed
    –> Processing Dependency: libuuid.so.1(UUID_1.0) for package: fontconfig-2.13.0-4.3.el7.i686
    –> Processing Dependency: libuuid.so.1 for package: fontconfig-2.13.0-4.3.el7.i686
    –> Processing Dependency: libexpat.so.1 for package: fontconfig-2.13.0-4.3.el7.i686
    —> Package freetype.i686 0:2.8-12.el7_6.1 will be installed
    –> Processing Dependency: libbz2.so.1 for package: freetype-2.8-12.el7_6.1.i686
    —> Package glibc.i686 0:2.17-260.el7_6.6 will be installed
    –> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-260.el7_6.6.i686
    –> Processing Dependency: libfreebl3.so for package: glibc-2.17-260.el7_6.6.i686
    —> Package krb5-libs.i686 0:1.15.1-37.el7_6 will be installed
    –> Processing Dependency: libverto.so.1 for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.5) for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.0) for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.15.1-37.el7_6.i686
    –> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.15.1-37.el7_6.i686
    —> Package lcms2.i686 0:2.6-3.el7 will be installed
    —> Package libICE.i686 0:1.0.9-9.el7 will be installed
    —> Package libSM.i686 0:1.2.2-2.el7 will be installed
    —> Package libX11.i686 0:1.6.5-2.el7 will be installed
    –> Processing Dependency: libxcb.so.1 for package: libX11-1.6.5-2.el7.i686
    —> Package libXext.i686 0:1.3.3-3.el7 will be installed
    —> Package libXt.i686 0:1.1.5-3.el7 will be installed
    —> Package libcom_err.i686 0:1.42.9-13.el7 will be installed
    —> Package libjpeg-turbo.i686 0:1.2.90-6.el7 will be installed
    —> Package libpaper.x86_64 0:1.1.24-8.el7 will be installed
    —> Package libpng.i686 2:1.5.13-7.el7_2 will be installed
    —> Package libtiff.i686 0:4.0.3-27.el7_3 will be installed
    –> Processing Dependency: libjbig.so.2.0 for package: libtiff-4.0.3-27.el7_3.i686
    —> Package openjpeg2.x86_64 0:2.3.1-1.el7 will be installed
    —> Package zlib.i686 0:1.2.7-18.el7 will be installed
    –> Running transaction check
    —> Package audit-libs.i686 0:2.8.4-4.el7 will be installed
    –> Processing Dependency: libcap-ng.so.0 for package: audit-libs-2.8.4-4.el7.i686
    —> Package avahi-libs.i686 0:0.6.31-19.el7 will be installed
    –> Processing Dependency: libdbus-1.so.3 for package: avahi-libs-0.6.31-19.el7.i686
    —> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
    —> Package expat.i686 0:2.1.0-10.el7_3 will be installed
    —> Package jbigkit-libs.i686 0:2.0-11.el7 will be installed
    —> Package keyutils-libs.i686 0:1.5.8-3.el7 will be installed
    —> Package libgcc.i686 0:4.8.5-36.el7_6.2 will be installed
    —> Package libselinux.i686 0:2.5-14.1.el7 will be installed
    –> Processing Dependency: libsepol(x86-32) >= 2.5-10 for package: libselinux-2.5-14.1.el7.i686
    –> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-14.1.el7.i686
    –> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-14.1.el7.i686
    –> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-14.1.el7.i686
    —> Package libstdc++.i686 0:4.8.5-36.el7_6.2 will be installed
    —> Package libuuid.i686 0:2.23.2-59.el7_6.1 will be installed
    —> Package libverto.i686 0:0.2.5-4.el7 will be installed
    —> Package libxcb.i686 0:1.13-1.el7 will be installed
    –> Processing Dependency: libXau.so.6 for package: libxcb-1.13-1.el7.i686
    —> Package nss-softokn-freebl.i686 0:3.36.0-5.el7_5 will be installed
    —> Package openssl-libs.i686 1:1.0.2k-16.el7_6.1 will be installed
    –> Running transaction check
    —> Package dbus-libs.i686 1:1.10.24-13.el7_6 will be installed
    –> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209) for package: 1:dbus-libs-1.10.24-13.el7_6.i686
    –> Processing Dependency: libsystemd.so.0 for package: 1:dbus-libs-1.10.24-13.el7_6.i686
    —> Package libXau.i686 0:1.0.8-2.1.el7 will be installed
    —> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
    —> Package libsepol.i686 0:2.5-10.el7 will be installed
    —> Package pcre.i686 0:8.32-17.el7 will be installed
    –> Running transaction check
    —> Package systemd-libs.i686 0:219-62.el7_6.7 will be installed
    –> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libpam.so.0 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: liblzma.so.5(XZ_5.0) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: liblzma.so.5 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: liblz4.so.1 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libgpg-error.so.0 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libgcrypt.so.11 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libdw.so.1 for package: systemd-libs-219-62.el7_6.7.i686
    –> Processing Dependency: libcap.so.2 for package: systemd-libs-219-62.el7_6.7.i686
    –> Running transaction check
    —> Package elfutils-libs.i686 0:0.172-2.el7 will be installed
    –> Processing Dependency: elfutils-libelf(x86-32) = 0.172-2.el7 for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.7) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.6) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.5) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.4) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.3) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.1.1) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1(ELFUTILS_1.0) for package: elfutils-libs-0.172-2.el7.i686
    –> Processing Dependency: libelf.so.1 for package: elfutils-libs-0.172-2.el7.i686
    —> Package libcap.i686 0:2.22-9.el7 will be installed
    –> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-9.el7.i686
    –> Processing Dependency: libattr.so.1 for package: libcap-2.22-9.el7.i686
    —> Package libgcrypt.i686 0:1.5.3-14.el7 will be installed
    —> Package libgpg-error.i686 0:1.12-3.el7 will be installed
    —> Package lz4.i686 0:1.7.5-2.el7 will be installed
    —> Package pam.i686 0:1.1.8-22.el7 will be installed
    –> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-22.el7.i686
    –> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-22.el7.i686
    —> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
    –> Running transaction check
    —> Package cracklib.i686 0:2.9.0-11.el7 will be installed
    —> Package elfutils-libelf.i686 0:0.172-2.el7 will be installed
    —> Package libattr.i686 0:2.4.46-13.el7 will be installed
    —> Package libdb.i686 0:5.3.21-24.el7 will be installed
    –> Finished Dependency Resolution
    Error: Multilib version problems found. This often means that the root
    cause is something else and multilib version checking is just
    pointing out that there is a problem. Eg.:

      1. You have an upgrade for ghostscript which is missing some
         dependency that another package requires. Yum is trying to
         solve this by installing an older version of ghostscript of the
         different architecture. If you exclude the bad architecture
         yum will tell you what the root cause is (which package
         requires what). You can try redoing the upgrade with
         --exclude ghostscript.otherarch ... this should give you an error
         message showing the root cause of the problem.
    
      2. You have multiple architectures of ghostscript installed, but
         yum can only see an upgrade for one of those architectures.
         If you don't want/need both architectures anymore then you
         can remove the one with the missing update and everything
         will work.
    
      3. You have duplicate versions of ghostscript installed already.
         You can use "yum check" to get yum show these errors.
    
    ...you can also use --setopt=protected_multilib=false to remove
    this checking, however this is almost never the correct thing to
    do as something else is very likely to go wrong (often causing
    much more problems).
    
    Protected multilib versions: ghostscript-9.07-31.el7_6.11.i686 != ghostscript-9.25-2.el7_7.3.x86_64
    

$ sudo yum repolist
[sudo] password for stewart:
Loaded plugins: fastestmirror, langpacks, versionlock
Loading mirror speeds from cached hostfile

  • elrepo: repos.lax-noc.com
  • nux-dextop: mirror.li.nux.ro
    repo id repo name status
    elrepo ELRepo.org Community Enterprise Linux Repository - el7 158
    google-chrome google-chrome 3
    nux-dextop/x86_64 Nux.Ro RPMs for general desktop use 2,715+2
    sng-base/7/x86_64 Sangoma-7 - Base 10,019
    sng-epel/7/x86_64 Sangoma-7 - Sangoma Epel mirror 16,251+2
    sng-extras/7/x86_64 Sangoma-7 - Extras 419
    sng-pkgs/7/x86_64 Sangoma-7 - Sangoma Open Source Packages 1,285+1
    sng-updates/7/x86_64 Sangoma-7 - Updates 2,235
    sng7-debuginfo Sangomga-7 - Debug packages 138
    sng7-testing Sangomga-7 - Staging 2,647+285
    virtualbox/7/x86_64 Oracle Linux / RHEL / CentOS-7 / x86_64 - VirtualBox 83
    repolist: 35,953
    $ sudo yum -v repolist
    Loading “fastestmirror” plugin
    Loading “langpacks” plugin
    Loading “versionlock” plugin
    Adding en_US.UTF-8 to language list
    Config time: 0.044
    Yum version: 3.4.3
    Loading mirror speeds from cached hostfile
  • elrepo: repos.lax-noc.com
  • nux-dextop: mirror.li.nux.ro
    Setting up Package Sacks
    Reading version lock configuration
    pkgsack time: 0.074
    Repo-id : elrepo
    Repo-name : ELRepo.org Community Enterprise Linux Repository - el7
    Repo-revision: 1588594502
    Repo-updated : Mon May 4 05:15:03 2020
    Repo-pkgs : 158
    Repo-size : 912 M
    Repo-baseurl : http://elrepo.org/linux/elrepo/el7/x86_64/, http://mirrors.coreix.net/elrepo/elrepo/el7/x86_64/, http://mirror.rackspace.com/elrepo/elrepo/el7/x86_64/,
    : http://repos.lax-noc.com/elrepo/elrepo/el7/x86_64/
    Repo-mirrors : http://mirrors.elrepo.org/mirrors-elrepo.el7
    Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:53 2020)
    Filter : read-only:present
    Repo-filename: /etc/yum.repos.d/elrepo.repo

Repo-id : google-chrome
Repo-name : google-chrome
Repo-revision: 1588180321
Repo-updated : Wed Apr 29 10:12:02 2020
Repo-pkgs : 3
Repo-size : 195 M
Repo-baseurl : http://dl.google.com/linux/chrome/rpm/stable/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:53 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/google-chrome.repo

Repo-id : nux-dextop/x86_64
Repo-name : Nux.Ro RPMs for general desktop use
Repo-revision: 1573036502
Repo-updated : Wed Nov 6 02:35:30 2019
Repo-pkgs : 2,715
Repo-size : 7.2 G
Repo-baseurl : http://li.nux.ro/download/nux/dextop/el7/x86_64/, http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:55 2020)
Filter : read-only:present
Repo-excluded: 2
Repo-filename: /etc/yum.repos.d/nux-dextop.repo

Repo-id : sng-base/7/x86_64
Repo-name : Sangoma-7 - Base
Repo-revision: 1543161601
Repo-updated : Sun Nov 25 08:00:34 2018
Repo-pkgs : 10,019
Repo-size : 9.4 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=os&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/os/7.6/os/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:55 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo

Repo-id : sng-epel/7/x86_64
Repo-name : Sangoma-7 - Sangoma Epel mirror
Repo-revision: 1563341482
Repo-updated : Tue Jul 16 22:38:05 2019
Repo-pkgs : 16,251
Repo-size : 29 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=epel&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/sng7/epel/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:55 2020)
Filter : read-only:present
Repo-excluded: 2
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo

Repo-id : sng-extras/7/x86_64
Repo-name : Sangoma-7 - Extras
Repo-revision: 1560955949
Repo-updated : Wed Jun 19 07:55:32 2019
Repo-pkgs : 419
Repo-size : 588 M
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=extras&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/os/7.6/extras/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:55 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo

Repo-id : sng-pkgs/7/x86_64
Repo-name : Sangoma-7 - Sangoma Open Source Packages
Repo-revision: 1586868364
Repo-updated : Tue Apr 14 05:46:23 2020
Repo-pkgs : 1,285
Repo-size : 3.2 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=sng7&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/sng7/sng7/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:55 2020)
Filter : read-only:present
Repo-excluded: 1
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo

Repo-id : sng-updates/7/x86_64
Repo-name : Sangoma-7 - Updates
Repo-revision: 1562945039
Repo-updated : Fri Jul 12 08:35:51 2019
Repo-pkgs : 2,235
Repo-size : 11 G
Repo-mirrors : http://mirrorlist.sangoma.net/?release=7&arch=x86_64&repo=updates&dist=$dist&staging=$staging
Repo-baseurl : http://sng7.com/os/7.6/updates/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:55 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Base.repo

Repo-id : sng7-debuginfo
Repo-name : Sangomga-7 - Debug packages
Repo-revision: 1584839363
Repo-updated : Sat Mar 21 18:09:28 2020
Repo-pkgs : 138
Repo-size : 620 M
Repo-baseurl : http://package1.sangoma.net/sng7/debuginfo/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:56 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/Sangoma-Test.repo

Repo-id : sng7-testing
Repo-name : Sangomga-7 - Staging
Repo-revision: 1588098043
Repo-updated : Tue Apr 28 11:21:05 2020
Repo-pkgs : 2,647
Repo-size : 2.1 G
Repo-baseurl : http://package1.sangoma.net/sng7/testing/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:56 2020)
Filter : read-only:present
Repo-excluded: 285
Repo-filename: /etc/yum.repos.d/Sangoma-Test.repo

Repo-id : virtualbox/7/x86_64
Repo-name : Oracle Linux / RHEL / CentOS-7 / x86_64 - VirtualBox
Repo-revision: 1586461535
Repo-updated : Thu Apr 9 12:45:38 2020
Repo-pkgs : 83
Repo-size : 6.4 G
Repo-baseurl : http://download.virtualbox.org/virtualbox/rpm/el/7/x86_64/
Repo-expire : 21,600 second(s) (last: Mon May 4 10:42:57 2020)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/virtualbox.repo

repolist: 35,953
$


(Shahin Nazir) #4

I can see GhostSript you have 64bit and 32 bit version. Try to remove it first. Then re-install ghostscript. GhostScript using for Convert FAX TIF to PDF format.

$ rpm -q ghostscript


(Hawk McDuck) #5

@snazir Thanks again for your reply.

$ sudo rpm -e ghostscript
error: Failed dependencies:
ghostscript is needed by (installed) freepbx-14.1-1.sng7.noarch
ghostscript = 9.07-31.el7_6.11 is needed by (installed) ghostscript-cups-9.07-31.el7_6.11.x86_64
libgs.so.9()(64bit) is needed by (installed) ImageMagick-6.7.8.9-16.el7_6.x86_64
libgs.so.9()(64bit) is needed by (installed) libspectre-0.2.8-1.el7.x86_64
libgs.so.9()(64bit) is needed by (installed) gimp-2:2.8.22-1.el7.x86_64
libijs-0.35.so()(64bit) is needed by (installed) gutenprint-5.2.9-18.el7.x86_64
libijs-0.35.so()(64bit) is needed by (installed) cups-filters-1.0.35-22.el7.x86_64
$ sudo rpm -e ghostscript-cups-9.07-31.el7_6.11.x86_64
error: Failed dependencies:
ghostscript-cups is needed by (installed) cups-1:1.6.3-35.el7.x86_64
$ sudo rpm -e cups-1:1.6.3-35.el7.x86_64
error: Failed dependencies:
cups is needed by (installed) ghostscript-cups-9.07-31.el7_6.11.x86_64
cups >= 1:1.4 is needed by (installed) hpijs-1:3.15.9-3.el7.x86_64
cups >= 1.2.1-1.7 is needed by (installed) gutenprint-cups-5.2.9-18.el7.x86_64
$ sudo rpm -e ImageMagick-6.7.8.9-16.el7_6.x86_64
[sudo] password for stewart:
error: Failed dependencies:
ImageMagick is needed by (installed) sangoma-pbx-2002-2.sng7.noarch
$ sudo rpm -e libspectre-0.2.8-1.el7.x86_64
error: Failed dependencies:
libspectre.so.1()(64bit) is needed by (installed) evince-libs-3.28.2-5.el7.x86_64
$ sudo rpm -e gimp-2:2.8.22-1.el7.x86_64
$ sudo rpm -e gutenprint-5.2.9-18.el7.x86_64
error: Failed dependencies:
gutenprint(x86-64) = 5.2.9-18.el7 is needed by (installed) gutenprint-cups-5.2.9-18.el7.x86_64
libgutenprint.so.2()(64bit) is needed by (installed) gutenprint-cups-5.2.9-18.el7.x86_64
$ sudo rpm -e cups-filters-1.0.35-22.el7.x86_64
error: Failed dependencies:
cups-filters is needed by (installed) cups-filesystem-1:1.6.3-35.el7.noarch
$

This doesn’t bode well.


(Jared Busch) #6

This is 100% out of the ordinary.


(Hawk McDuck) #7

@sorvani Thanks. I would expect that some of these packages should be copacetic with CentOS and FreePBX, for example, gnome-desktop, gparted, chrome, synergy, timeshift, FOP2, and wireshark. (gimp I did remove, see above.)

Webmin possibly not, nor maybe Zoiper.

Your thoughts?


(Hawk McDuck) #8

I’m somewhat surprised that nobody else has responded to my dilemma over the past week, not even the good folks in design with Asterisk or Sangoma. So I suppose I’m pretty much on my own on this from this point.

I realize that not being able to upgrade CentOS is not a sustainable option, so here’s what I’m proposing to myself to resolve this issue:

  1. Backup FreePBX from Admin–>Backup and move the backup file to another computer for safekeeping. Record the Activation ID.
  2. Remove the 120GB SSD boot disk from the FreePBX system, put it in safekeeping, and physically install a new SSD.
  3. Perform a fresh installation of FreePBX 14 from the official FreePBX distro and update the Activation ID from Step 1.
  4. Update FreePBX with:
    # sudo yum update
    # sudo fwconsole ma upgradeall
  5. Copy the backup file from another computer which was performed in Step 1 and restore the file from Admin–>Backup & Restore

I hope that should cover it. Anyone have comments?


(Dave Burgess) #9

Yeah, that should do it.

You need to review the steps in the Wiki about moving your installation to new hardware and transferring the Activation ID from the old installation to the new, but other than that, you should be good to go.


(Hawk McDuck) #10

@cynjut Thanks for your reply.

I finally got around to re-installing FreePBX using the five steps I proposed above. Fortunately everything seems to have gone without a hitch, at least as far as I can tell at the moment. The System Overview screen on the Dashboard is showing all green, and my weird and motley collection of ancient Cisco, Aastra, Nortel and Sangoma IP phones all have come up, and I can make outgoing and receive incoming calls.

I decided to “live dangerously” again and installed FOP2 and Webmin. So far, so good.

Thanks for those who helped out.


(system) closed #11

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.