FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX with USB modem/dongle


#21

Thank navaismo,

In this case I think my dongle is now showed as S and not USB. like u see in the screen shots

Am i right to think my files should be pointing at /dev/ttyS* instead f /dev/ttyUSB* ?

Below are the 2 shots before connecting Huawei dongle and after


#22

I think that the issue you are having here is that you are not executing the little binary that changes the mode from mass storage to the actual mobile modem. As you can see, the dongle is initially detected as a CD-ROM, because that is meant to be the easy way to connect to a Windows machine. That “virtual” CD-ROM" contains the windows drivers that are auto-installed when you first plug the dongle on a Windows machine. On Linux, that is completely useless, and counterproductive too, that is why there is a small binary, I don’t recall the exact name, but I think it is called usb_modeswitch. After you plug the dongle, you must run that executable, which will take care of switching the dongle from “CD-ROM” mode to “Mobile Modem” mode. Once you do that, you will see the modem on /dev/ttyUSBx, where x is a number.


#23

I also installed this like u can see


#24

It is not enough to just install it, you are supposed to execute it after you plug the dongle, otherwise the dongle will never get switched, unless the udev rules are modified for automatic execution, but I don’t believe the install process modifies such rules.


#25

How do i execute it, am some how lost


#26

You can read how to use it from the following website

http://www.draisberghof.de/usb_modeswitch


#27

Hello , I’m not an expert on responding on forums normally as this is probably my 2 time trying to help someone from here , but I have a lot of experience on chan_dongle as I had to install some from last 2 years.
First you could at list try to see if that dongle is found on the USB devices with the lsusb command ( if the command is not found , yum install lsusb) .
Then I am sure you will find it difficult trying to compile the chan_dongle from source as one of the key difficulties was some (2 files ) were missing from the master repo and I had to find them on older version of it in a tar.gz .

Resuming it is not a easy task as you will need to have good Linux expertise for troubleshooting and some on asterisk to check if it is working.

I wouldn’t mind to help you but out of the forum .
Some things you should be checking:

  • does that model as a voice channel ?
  • is it already unlocked or can it work with the SIM you have?

In case you would like my help please tell me how could we communicate ? Skype , sip …


#28

Thanks Diogo, we can arrange a skype chat and after I will share our achievement with the good pple on the forum

My skype is matsyuf, kindly tell me the time I can catch you online, I dont know which country you are in but am in Uganda , Kampala and guess u will be able to tell the time difference btn ourselves

Regards


#29

Hello,

I have also noticed that all configuration files are pointing to a file /dev/ttyUSB* but i dont have these files in dev as you may see in my screen shots, i try to list file with ttyUSB and gives nothing

Below is a list tty files page by page;


#30

I would like to know how i can determine which file my dongle uses in /dev/??? since I dont have the default /dev/ttyUSB*


#31

We already told you how if you just ignore us and ask again the same questions will not solve your problem.

First you need to enumerate your device as a non storage device, other user told you about that. Read the manual of your tool to do that. Then try again.


#32

Hello All,

I am now able to have files /dev/ttyUSB*. I achieved this by creating a Huawei file in dev rule with the command. The file in path etc/udev/rules.d/50-huawei-e1552.rules and added;-

SUBSYSTEM==”usb”,
ATTR{idVendor}==”12d1″,
ATTR{idProduct}==”1446″,
RUN+=”/lib/udev/usb-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t option-zerocd”

Restarted my PBX and now

But when I logged into CLI i got an error below

Then I read on some forum and was told i can ommit Audio=/dev/ttyUSB1 and data=/dev/ttyUSB2 in the file /etc/asterisk/dongle.conf under section [dongle0] and replaaced with imei below is my file

another problem i have is when i try to load module dongle on CLI, i get an error too

Where may i be going wrong.

regards


#33

You have

chang_dongle

and it is:

chan_dongle


#34

Make sure your modem is working before you start asterisk

https://content.konekt.io/blog/using-at-commands-with-the-huawei-e303/


#35

Hello, I think my modem is, i also went to CLI but got some error too


#36

When you are connected then AT (return) will respond. if not, you have more work to do


#37

Yes AT works, I was also able to call my GSM mobile number from AT command, I have also sent screen shot above showing AT response.


#38

Module load chan_dongle.so error I have handled by unloading module and reloading it though now my device cant be showed with dongle show devices command, what could i be missing


#39

I request help, wondering my dongle isnt recognised in the command #dongle show devices


#40

Configuration mostly… Now you need to reach the help for that channel driver, and i mean from the creators. Since this is not an Asterisk or FreePBX issue I suggest to read the manual of Chan_dongle to know how to configure it and if that doesn’t work go to the appropriate channel to ask for help.