FreePBX with USB modem/dongle


I am newbie and request help with FreePBX.

I have FreePBX on my virtual machine and Huawei Modem/dongle (Model: E153u - 2 ). I would like to configure the modem with my Freepbx.

Kindly help take me through the steps i should take to have the modem recognized by the freepbx system and also configure inbound trunk.


Please do a bit more research and make some attempts of your own. Post back if you run into issues and Google fails you.

Ok Thanks Overkill I will keep everyone posted

Am having trouble installing usb_modeswitch and data

Error messages tell you what’s wrong…

You need to install/update glibc and systemd

glibc is pretty commonly installed, I bet you can do a yum update glibc to take care of that…

I have tried installing systemd but i get error

The instructions were for CentOS 6, it appears you’re on 7…not sure how best to help you here since it’s a different version.

I think this is a case of “Welcome to Uncharted Territory - please make a map so everyone else can follow your success.”

I have 6.6

For this case I have a feeling there is need to upgrade my distro from 6.6 to 7. I have read on many pages and its said systemd cant be installed on 6.6.

Problem I have Freepbx distro and looks like most come with 6.6. I am setting up this to have it work with my dongle to test my services.

Do i have to setup freepbx separate on different linux eg ubuntu than getting fully built disto ?


I see module could this server the purpose with dongle ?

The RPM you downloaded is for EL7 (aka CentOS7). Download the one for EL6.

I am successful with EL6 download now having trouble with configuring dongle, I get error with automake - no ‘’ found for any configure output.

maybe its because am running asterisk13 and am downloading dongle for asterisk11

I would like to know how i can setup dongle on asterisk 13 which am running within my FREEPBX


Error - automake - no ‘’ found for any configure output. shouldnt be paid attention to (as per

so igot chan_dongle for asterisk13


Did the necessary steps

When go to CLI and run command #Dongle show device i get error

wha am i doing wrong

More info

While this might sound mean, I don’t intend it to be.

This is a pure Asterisk problem - while there might be people here that might be able to help you, I think you’d be more likely to find the resources you need on the forums. I’m certainly not suggesting that you need to stop posting - I’m just saying that the folks at might be a better resource since they are one layer closer to the system then we are.

Once you get the details worked out, I’m sure we’d all love to hear about how you did it, but this doesn’t really have any relation to FreePBX. At least, not until you get it working and put in an Issues ticket to add it as an enhancement.

Its fine Dave, I will keep posting am quit sure someone out there will or may have experienced the same problems to help or make use of the post

Actually is a Chan_Dongle issue not asterisk not freepbx.

The error is telling you that Chan_Dongle is already loaded in your asterisk, and the secod is telling you that the interface on the linux system doesn’t exist. So first of all check which device is using linux to configure the USB-CDC by running:

Or unplug the usb modem run the command

attach again the usb and look in the log which tty is assigned to it.

Then go and edit the /etc/asterisk/dongle.conf file accordingly. Save changes, go back to the cli, unload the module, load the module and try again.