FreePBX with Adtran TA924

So I migrated all of my configuration from an old FreePBX 13 on-prem to a new FreePBX 15 on AWS. The main difference is that I provisioned the SIP trunking and extensions as CHAN_PJSIP, rather than the legacy CHAN_SIP. All of the desk phones are working fine.

The only quirk I’ve encountered is I have Adtran TA924’s at our larger sites for breaking out some analog lines. Pointing the Adtran endpoints to the new FreePBX, the new SIP port, etc. was all pretty straightforward. I’ve verified those settings are all changed over okay.

Here is where the quirk is. The analog endpoints are SIP registered just fine. They can outcall just fine as well. But when incalling them the endpoints don’t ring. To remove inbound call routes from the picture I tested them out with another local desk phone calling them.

Would choosing CHAN_PJSIP cause issues for an older (Gen. 1) Adtran TA924? It’s just odd that the endpoints are SIP registered and can outdial just fine.

Here are links to some of the logs. First the Asterisk log for a call that didn’t ring, calling from local desk phone x613 to a cordless analog phone at x641 --> Secondly, a SIP debug capture from the Adtran itself, where I was test calling from my x101 desk phone to an analog fax machine at x644 -->

A couple of smaller sites only had a single fax machine. So I just use a Cisco SPA112 in those cases. Moving things to point over to the new FreePBX worked fine for them. They can outcall and incall okay.

Any ideas about the Adtran TA924?

Is this defined as a trunk on the Adtran?


Including the port?

In the CLI config, would look like:

  sip-server primary FREEPBX-WAN-IP udp 6060

Yep. Below is from the config (public IP redacted of course).

sip-server primary {FREEPBX-WAN-IP} udp 6060

This is the first foray into using CHAN_PJSIP, so I’m not sure if registration would work, outcalling would work, but incalling wouldn’t work if the Adtran TA924 isn’t compatible with CHAN_PJSIP.

Nothing cares about the channel driver. Assuming things are compliant to the RFC, then SIP is SIP.

The ADTRAN uses some channel driver of their own design. Asterisk (under FreePBX 15) uses chan_pjsip.

That’s why I’m wondering if there was a driver communication issue then that should mean more of an all-or-nothing scenario. In this case the FXS extensions are registered and can outcall. Only incalling is failing. Digging into the Adtran config. To see if there something causing the inbound calls to not be accepted on the non-standard port I’m using (i.e. - UDP 6060).

Try fixing the From address coming from FreePBX. You can set the From domain in the PJSIP trunk advanced field. Set it to match the external IP. The Adtran is not recognizing the incoming traffic as being affiliated with the trunk, and that might be why.

You may get more answers by enabling voice debug on the adtran, debug voice verbose

Thanks for the info! Since I am using a non-standard SIP port after the FreePBX switch, I’m wondering if it’s possibly something related to this --> Adtran TA924 Can only call out, not receive calls.

It sounds like it’s more of an Adtran issue I’m thinking. So I posted a question on their community forum. We’ll see what transpires.

This Adtran TA924 is so old and apparently doesn’t play well with non-traditional SIP ports. Plus years ago it was needed for multiple fax lines, dial-up credit card terminals, multiple cordless phones, PC modems, etc.

Looking at the site requirements today, we only need a main fax line, one analog phone line, and a cordless phone. So I am retiring the TA924, and deploying a Cisco SPA112 and a Yealink W52P I have lying around. Testing them out, they work perfectly with the new AWS FreePBX 15. Beats spinning my wheels for too long!

Don’t do that! I absolutely LOVE my Adtrans! I find them abandoned (and claim them) all the time - it’s one of the first things I look for at new client sites when I tour the Phone Room.

Register for an account on Adtran’s site and claim the devices - you will then be able to download the absolute latest firmware (they have the procedure posted - the current firmware for them is too big so you will need to delete the existing firmware before you upload the new - don’t worry, it works fine) and once you have them flashed to current, I bet they work fine.

We have LOTS of them deployed all over the place - they are the best multiple-device SIP-2-Analog device I have ever used and they work great - just get current on the firmware and they are good.

E-Mail me if you want a copy of the procedure I wrote - this forum won’t let me upload a .doc or .pdf - dang it.

1 Like

Yeah I love Adtrans too going back to the late 1990’s. I had Adtran Atlas 550’s deployed years ago for splitting out voice and data. They were rock solid, and had lifetime support included. These TA924’s I inherited when our losing carrier didn’t want to claim them back at our larger sites. I did download and apply their latest firmware when I first configured them to work with our FreePBX 13. They worked like a champ.

It seems like such as basic configuration change. Literally the only thing that changed is the SIP server IP and SIP port. So it should have been straightforward. I could understand if outcalling didn’t work, if I forgot to add the new SIP trunk to the group with the proper class of service and dial plan. But this was incalling from other local extensions.

Tell you what. I will have three Gen. 1 TA924’s retired when my migration is finally done. When I have them cleaned off I will DM you if you’d like to use them. :grinning:

1 Like

Heck yeah! the 924’s are the best (density) - I am using them with Odd-Port SIP, but they were configured that way from the get-go, so I wonder if the change is what broke them.

For just a couple of ports an ATA would be easier though - our deciding-point is more than 4 ports and we always use them - less than 4 and we either use ATA’s or if they have a box, a card with FXS ports.

Yep. My largest site only has 4 analog lines nowadays. Four fax machines. So I am just dropping in a couple of Cisco SPA112’s. Please keep in mind these are the first generation of TA924’s. Specifics below. Anyhoo, I’ll get back with you when I have pulled them and cleaned them off.

Firmware Version A4.11.00.E
Part Number 4210924L1

@GSnover just an FYI that I am about a week away from having the 2 Adtran Gen 1 TA924’s out of production. And then a spare one as well. So I will be getting with you soon to arrange getting them to you. :smile:

1 Like

Awesome! I will figure out how to send you a FedEx Call Tag! Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.