FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX web interface is down


#1

Our phone system went down over the weekend and wouldn’t boot up without us doing a fsck and repairing some files. We’re working on getting a backup server in case this one goes down…but after it came back up the web interface is down and we are seeing issues with phone setup and parking calls. When I try to run amportal restart I am getting some errors:

The error is referring to /var/www/html/admin/libraries/Composer/vendor/symfony/polyfill-php55/bootstrap.php
I checked our system and I dont have the polyfill-php55 directory, but I do have polyfill-php56

At some point it must have tried to update? I’m still pretty new to this system. Any idea of how I can get this fixed? Let me know what other info about the system you need. Thanks!


#3

Any suggestions?


(Itzik) #4

I didn’t fully read the error you are getting, but since you are asking for suggestions, I’d suggest to maybe consider updating your PBX, you seem to have an old version.


(Dave Burgess) #5

I don’t know how old your system is, but amportal has been deprecated for about four years, so if you are running a system where that is what you are using to manage the system, an update is definitely in the cards.

What version of FreePBX/Asterisk are you on? Is this a ‘hand built’ installation or a Distro?

Depending on the answer to that question, your upgrade path could be anywhere from trivial to “Oh Lord, what have I done.” :slight_smile: If we assume it’s trivial, a ‘yum update’ could be all you need to get back on track.


(Rob Thomas) #6

That machine is dead. It’s missing a bunch of stuff. Restore /etc/asterisk from a backup and see how it goes (any age backup will work). If MySQL is still there, and still contains data, you can probably revive it, but depending on the size of your installation, it may be quicker and easier to just rebuild it on a new machine.