I have a soft phone installed on my cell phone and it can connect to FreePBX when it’s connected (via WiFi) to the same network as the FreePBX. Also I have the OpenVPN client installed on the same cell phone and it will connect to FreePBX when I’m at a Starbucks (for example). However, the softphone will not connect to FreePBX when I’m at Starbucks. What am I missing in my setup?
Home network =
OpenVPN network =

Any help provided is greatly appreiated.


In your VPN setup do you have strict routing (otherwise known as Redirect Gateway) enabled on the FreePBX VPN. As well as the route enabled on it that it autocreates?

Hi there

I have this:

Any reason for the 2nd route of Not sure where that is coming from but I dont think it matters. On your cell phone when you turn on does it connect to the VPN?

If it does connect are you able to ping your cell phones VPN address from the FreePBX cmd line?

Lastly it may be a setting within the VPN setup on the cell phone causing it. Maybe a setting on the cell is not telling you phone to send all traffic through VPN.

Note: When on my home network, the Zoiper soft phone will register with the FreePBX at The minute I launch the OpenVPN client (and get and address of the soft phone shows “Acer WiFi registration failed”.
Thanks very much for your assistance.