FreePBX v15 fwconsole reload failed after installing local modules

freepbx-15
Tags: #<Tag:0x00007f702915d6f0>

(Roman Ponkrashov) #1

Hi community.

I will say in advance that a great many such topics were created on the forum, but nevertheless, I decided to try my luck, because I did not find a discussion of a similar problem that I had. I also tried various methods for resolving problem situations, which I will report below in a post.

So, to the problem:

I am trying to create a FreePBX distribution, in which I have included my scripts, the software I need. Asterisk 16.9.0 is installed from source, FreePBX 15 too, but I ran into a serious problem when I tried to install modules that I had already downloaded in advance.

When installing FreePBX, I use the following command:

./install -n --dbuser = user --dbpass = pass

Installation is successful, then I try to install modules for FreePBX, which were already downloaded earlier and included in the distribution.

I move the necessary modules to /var/www/html/admin/modules/ and then install using the fwconsole ma installlocal command.

Installation is successful, after which I do:

fwconsole chown
fwconsole reload

and get:

[root @ headstack ~] # fwconsole reload
Reload Started

In php-asmanager.php line 495:

fclose () expects parameter 1 to be resource, boolean given

reload [–json] [–dry-run] [–skip-registry-checks] [–dont-reload-asterisk]

Moreover, I noticed a similar behavior during tests, when I completely used fwconsole to install the necessary modules with the command:

fwconsole ma downloadinstall

The result is the same anyway.

When I get to FreePBX on the Web-interface, I see that an exclamation mark appears next to Asterisk, which says in the text that Asterisk was launched as early as 10 minutes, supposedly not using FreePBX startup scripts.

The modules I’m trying to install

accountcodepreserve announcement api arimanager asterisk-cli backup blacklist bulkhandler calendar callback callforward callwaiting cel certman cidlookup customcontexts cxpanel daynight dictate directory disa donotdisturb dundicheck endpointman extensionsettings fax filestore findmefollow fw_langpacks hotelwakeup iaxsettings irc ivr languages manager miscapps miscdests outroutemsg paging parking pbdirectory phonebook phpinfo pinsets presencestate printextensions queueprio queues restapi ringgroups setcid speeddial superfecta timeconditions tts ttsengines userman vmblast weakpasswords ucp webrtc xmpp

I ask for any help in resolving this problem, or your thoughts on how to resolve this incident. Ready to provide any information for debug.


(Roman Ponkrashov) #2

In order for everything to work, you need to attach the asterisk.conf file with your custom settings, because later changes to this file give no result. In particular, I tried to change the owner of asterisk.pid in asterisk.conf. Thus, when reinstalling with the obviously existing Asterisk configuration file, everything works, including after rebooting the machine itself on which the server is deployed.

The problem is solved, the post can be closed.


(Joshua Cadman) #3

Sorry I am new to this and have the same issue, what has to be done to get this fixed?


(Roman Ponkrashov) #4

In order to solve the problem specifically described by me, you need to write about the following in the Asterisk configuration file ‘asterisk.conf’

[options]
runuser = asterisk
rungroup = asterisk

[files]
astctlpermissions = 0660
astctlowner = root
astctlgroup = apache
astctl = asterisk.ctl

In fact, you can take a sample of the configuration file that was generated by the Asterisk installer, then add or uncomment these options in the configuration file.

Please note that this file should already be in /etc/asterisk/ when you try to run the FreePBX 15 installation script.

Nothing attractive, I took a sample, uncommented what was needed and added the necessary options. Unfortunately, you cannot attach .conf files to the forum. Leave a contact mail, if necessary, I will send.

Hope this helps you.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.