Freepbx upgrade from 2.5 to 2.7 breaks "early dial" SIP clients


Today I decided to upgrade my stable Freepbx system to All went well except for one blocking issue:

some SIP clients could not dial. These clients were all Grandstream GXW-4008 ATAs. They are configured for “early dial” which I guess is what’s failing (also known as “484 Incomplete Address”).

Since I did this on a production server and everyone was going crazy when they found out they couldn’t dial (actually only these ATA phones; other SIP client types worked fine), I restored the backup copy and all worked fine again.

What puzzles me is what could have changed in FreePBX so as to affect “early dials” (or at least this is what appears to be happening).
In the Asterisk log, nothing is registered when an ATA tries to call out (by the way, they can all receive correctly, but can’t dial out).

I will need to bring up a test system but in the meantime I would like to know if anyone has any ideas.


Found and reported, please see details here:

just pushed out the new module that fixes this.

I believe there is an existing bug report filed for that backup migration.

It seems to work now.

However, I had to manually delete the backup table and reinstall the backup module because I got these messages:

Cannot migrate Backup table DB Error: already exists


Not found

The section you requested does not exist or you do not have access to it.