FreePBX upgrade from 2.4 to 2.7 - zaptel failure on reboot

Trixbox 2.2, CentOS 4.8, FreePBX, Asterisk 1.2 - Single core, single proc machine with 2 TDM400P 4FXO cards (8 POTS lines) installed, supporting 15 IP extensions with light call volume.

This machine has been running great since 2007, and was my first (and so far only) asterisk installation, so I’m pretty sparse on technical knowledge.

After upgrading via module admin to over the weekend, asterisk will not start. Digging deeper I found the zaptel information is shot.

genzaptelconf and ztcfg both produce:

Notice: Configuration file is /etc/zaptel.conf
line 0: Unable to open master device ‘/dev/zap/ctl’

/etc/zaptel.conf is blank except for global data (used to have 2 Wildcard spans with 4 channels each).

Right now, I have a system with broken a zaptel install, a broken half-dahdi install, and no phone access. How do I clean this up?

How I got there:

Updated to 2.7.01 through module admin in FreePBX - rebooted the system - no incoming calls. Found out zapata wasn’t registering. lspci shows the cards.

I have tried replacing the broken zaptel.conf with the old file & restarting.

I have tried pulling and swapping the physical cards.

I have tried removing zaptel, zaptel-modules, then reinstalling using yum -y install zaptel*.

I have tried running the trixbox script, then rebooting and running yum -y update.

I have run yum -y update on its own (nothing to do).

I have tried downloading and installing to dahdi, then removing dahdi by hand because I have no idea how to get asterisk to recognize the change. That was not a great idea, as now I have both zaptel and fragments of dahdi on the system.

I have tried installing oslec and oslec modules (yum -y install oslec oslec-modules) after starting to receive: WARNING: /lib/modules/2.6.9-34.0.2.EL/extra/zaptel.ko needs unknown symbol oslec_echo_can_update (still receiving the warnings).

I am willing to update, upgrade, fresh install, etc, but I’d need to know how to preserve and restore the IVR, extensions, voicemail, etc before doing so.

I would prefer a solution that simply fixes the zaptel/oslec/dahdi issue on the current system.

Please help?