freePBX upgrade error modules

Hi this message recived when i log in freePbx “setup or Tools” upgrade da 2.1.1 at 2.2.0Beta1.
: Fatal error: Cannot redeclare gabcast_hook_core() (previously declared in /var/www/html/admin/modules/gabcast/functions.inc.php:4) in /var/www/html/admin/modules/pbdirectory/functions.inc.php on line 4

Help me please

ssh into the box rename or move gastcast Module

amportal restart should start now

tenkyou this problem is resolved.

Ciao!

Hi I have the allmost the same problem only that I have upgraded the freepbx 2.0.1 to 2.1.1 and the webserver cannot recognize the installed modules, it is telling me that the module is unknown . Can you please tell me what can I do?

login with SSH and tar up the /var/www/html/admin/modules folder and then del the modules in there (keep the .tar)

go to 2.2.0 beta1 2.1.1 is outdated

cd /usr/src/
rm -rf freepbx
svn co https://svn.sourceforge.net/svnroot/amportal/freepbx/trunk freepbx

./install_amp --force-version=2.1.1

now amportal start and go in and do the module admin once more

hit the online repos and load what need,
only load the modules you use…

OH Yea when you get it right do a backup and go in a tar the modules once more and keep the file (if something is updated later and you have issues you can rollback to the these modules…saved me some time many times…