FreePBX trunk to 2N VoiceBlue for incoming calls


(Adam) #1

Hello,
I have a problem with setting up FreePBX trunk for 2N VoiceBlue for incoming calls.
I´m converted from old Asterisk PBX to FreePBX 15. On old Asterisk PBX it´s works, but I can´t figure it out how to make it to work on FreePBX.
My solution:
On 2N VoiceBlue I have set two groups (one for each SIM card) and these groups call to 1001 or 1002 number (direct to the Asterisk PBX) when some call come in. So I can recognize from which SIM card call coming.

On old Asterisk PBX I have this sip registration:
[Brana]
type = friend
context = invoiceblue
host = dynamic
username = Brana
secret = AAA
disallow = all
allow = alaw
dtmfmode = rfc2833
qualify = yes
nat = no

and in extensions.conf I define what happen when 1001 (from SIM1) or 1002 (from SIM2) come in (call is directed to some IP phone).

BUT in FreePBX I don´t know how to configure it on FreePBX. I´m using chan_sip trunk and i have defined inbound route, but my best result is incoming call has served by default “s” extension.

My setting on FreePBX is:
trunk setting:

Outgoing:
Trunk Name
Brana
PEER Details
type=friend
context=from-internal
host=dynamic
username=Brana
secret=AAA
insecure=invite
disallow=all
allow=alaw
dtmfmode=rfc2833
qualify=yes
nat=no

Incoming:
USER Context:
from-trunk
USER Details:
type=friend
context=from-trunk
insecure=port,invite
host=XXX.XXX.XXX.XXX
username=Brana
secret=AAA
dtmfmode=rfc2833
disallow=all
allow=ulaw
qualify=yes
nat=no

Register string:
1002

It works, it call (both ways) but incoming call is identified as a mobile number of source and not as a 1001 or 1002 so I can´t point to the different IP phones.

I thing, there is problem in registration (2N voice Blue is not registered to FreePBX correctly)

Can some one navigate me what should I fill to general setting of the trunk and to Incoming section in sip Settings and how to set Inbound Route?


(David55) #2

It looks to me as though you have a security issue. You have a type=friend, with authentication of INVITEs disabled, in the from-internal context, which is the context normally allowed to make chargeable calls.

As another general point, if you are able to use a static address, you should always do so, so should not need to register. It looks like you may have the same peer as both static and dynamic.

Although I’m looking at this from an Asterisk point of view, rather than a FreePBX one, I think the security issue is sufficiently obvious and important that it needs highlighting.


#3

Based on my settings for a similar device:
Trunk Name: Brana

PEER Details:
host=dynamic
username=Brana
secret=AAA
type=friend
qualify=yes
context=from-trunk
disallow=all
allow=alaw
dtmfmode=rfc2833
qualify=yes
nat=no

Incoming tab: leave everything blank.

If you still have trouble, at the Asterisk command prompt type
sip set debug on
make a test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.
If you are too new to post links, post the last 8 hex characters of the link URL.


(David55) #4

Unless there is another extension or trunk that will have the same IP address, make type=friend be type=peer (improved security). If you actually know the static address, which it looks like you do, change host=dynamic to host=xxx.xxx.xxx.xxx (improved security) and remove the registration configuration from the other end. Unless you have a situation that is falsely identified as NAT (NAT is indicated, on the sip set debug on output, but there is no NAT between Asterisk and VoiceBlue), and the forcing of rport, or use of comedia would break something, “nat=no” serves no useful purpose (people often think that nat=* applies to cases where Asterisk is inside NAT and the extension or trunk endpoint is outside, but only actually applies to the opposite situation, and the default covers most cases).


(Adam) #5

Thank you all for replies, finally I figured it out becaouse of you! :slight_smile:

The working setting contains type = peer and host = dynamic for both
And for Outgoing must be set Trunk name same as username of registration on 2N (don´t know why, because the name of column is Trunk name).

and make new dialplan in extensions_custom.conf for my 1001 and 1002 incoming extens.

But after all I still think there is more simply solution without need of write something into extensions_custom.conf. So, maybe in future I crack it out too :slight_smile:


(David55) #6

Most people don’t require separate incoming and outgoing specifications.