FreePbx Trunk Setup

At the moment my configuration is FreeBpx and A2Billing. The trunk configuration I have got is surname, password, and address (…the problem is I have not got any idea how to set trunk (in FreePbx or A2Billing or in both) up with this trunk info they (trunk provider) provided me with the assurance that they added my ip as a trusted one with their server.

It would be a great help if you could tell me where (FreePbx or A2Billin or in both?) exactly I need to set up trunk (and how)

Can you please help.

Kind Regards

host=ip address

You can use allow and disallow as usual to pick CODEC.

Thank you ever so much…

I have done the way you showed but when I dial my did number it receives the call and reads out the balance on my (test customer) account and asks to dial the destination number after it says how many minutes I have left and it starts ringing and after ringing several times it says the destination number isn’t available but I assume it never goes to the destination as I have checked. But on my Call Log (FreePbx) this is the call log.

If you could tell me where exactly the problem is would be a great help.

Thanks again for your support.

Channel Source Clid Dst
Disposition Duration

  1. 2013-09-01 00:42:14 SIP/VSR-00… SMTel “Anonymous” s ANSWERED 00:18
  2. 2013-09-01 00:41:25 SIP/DID-00… Anonymous “Anonymous” 42035190334 ANSWERED 01:07
  3. 2013-09-01 00:30:02 SIP/46.4.1… 300 “300” <300> s ANSWERED 00:00
  4. 2013-09-01 00:30:01 SIP/46.4.1… 300 “300” <300> s ANSWERED 00:00
  5. 2013-09-01 00:30:00 SIP/46.4.1… 300 “300” <300> s ANSWERED 00:00
  6. 2013-09-01 00:29:59 SIP/46.4.1… 300 “300” <300> s ANSWERED 00:00


As nothing was working just to double check I tried with a free trunk provider and it worked. The (sip-au) gave me

Username: 123328688
Password: 0089952000

It worked without any trouble now my real trunk provider gave me username, password, and web address as well, (it is a reseller account) which doesn’t work.

I am guessing that I must have been making some mistakes in configuring the reseller account.

Any help please


I have worked it out, instead of all the information if I just put only the ip address the call goes through. But the problem is in my reseller’s screen (I went to service provider, and he showed on his voipswitch screen, where he can monitor all the calls in realtime, it says some other codec is used while expected g729. He tried to configure it from his voipswitch but failed it doesnt work and asked e to configure from my side/freepbx while he doesn’t know how freepbx works)…I looked everywhere but couldn’t find any codec settings in freepbx.

Advice would a great help…


You will need to buy licenses for g729 from Divium to suit and allow them by preference in your trunk settings