Freepbx treats partial external number as extension

Hi there,
I have a small test setup with 3 extensions 301,302,303.
I have an Outbound route dial pattern as (UK numbers)
prepend +44
prefix 0
Match Pattern [12378]XX.

When I dial the number before going off hook so all the number is sent at once, outbound calls work.
However when I go off hook first and dial the first 3 digits I get “Your call cannot be completed!”

Is there some way of filtering numbers starting with 3 and allowing all others to be longer external numbers?

Many thanks

The number shouldn’t be sent at once; there should be a final digit timeout, as far as I know.

UK number are difficult because of size variations, and, at least in the System X days, the network itself used to apply a timeout on shorter numbers; the advice for those in the know, and specifically for pulse dialling, was to dial an extra 1 at the end, as the network would ignore it it, but it would bring the number up to the maximum length.

I think the only way to get what you want in Asterisk is to define full patterns (which is basically what the main exchanges did/do). I rather suspect that will be painful through the GUI.

The only other approach is to increase the digit timeout:

There may well be a way of doing this through the GUI, but this will cause annoying delays when dialling, and you may need to use patterns ending in ! to speed things up when you know a number is short.

Note that you haven’t said what technology you are using on either the phone or the trunk. It is not normal for SIP phones to do off hook dialling, so I suspect you are using analogue phones.

As I’m only used to use it with SIP phones, which with on hook dialling, I’m not completely sure whether a timeout is applied with ., or whether there actually has to be a pattern that is longer and doesn’t involve wildcards.

One other point. I’m pretty sure that the voice message you are receiving is coming from the public network, i.e the numbers are being treated as PSTN numbers, not local ones.

Hi David, thanks for the reply.
I’m using a Polycom vxx201 VOIP phone for testing. I’m beginning to think it the phone settings. Just looked at the Phones internal settings and it has it’s own pattern matching table. I think I’ll need to look upon this first.

I think you will find that all SIP hard phones have “dialplans”, which is the term the phone suppliers use for that table, Off hook dialling is faked by the phone.

Thanks so much for your time. I think I’m on the right path now.
I’m new to FreePBX and VOIP, hence a test setup.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.