Freepbx times-out - must restart asterisk


(Kappclark) #1

I am running FreePBX in a virtual machine. Asterisk 18.3…I can dial out and the viop provider works fine.

After awhile, however, the system will say all “circuits are busy…” …the remedy which always fixes theis is going to Asterisk CLI and doing core restart now

Is there any way to prevent this ?? I am thinking it drops the connection somehow to the sip provider (voip.ms)


Not receving all incoming calls
(TheJames) #2

Your best bet is to get logs when it goes in to this state.

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug


(Jared Busch) #3

You can most likely just disable the trunk, apply config, then reenable the trunk, apply config also. If that works it is mostly likely too long of a registration period.

Back when chan_pjsip was first released I had issues with VoIP.ms and stayed on chan_sip.

Eventually, I made it a point to switch everything to chan_pjsip and took the time to actually deal with this.

At the time VoIP.ms said, of course, “we do not support PJSIP.” Well we all know that means nothing because SIP is SIP. Our local channel driver doesn’t mean anything to our provider, assuming all the sip header and setting are sent the same.

After pushing, VoIP.ms pointed me to a wiki article that I can no longer find. But I posted about it on another community in June of 2017.
But basically, they said to reduce the expiration time from 3600 to 120.
image

Their current wiki article on the subject does not say anything about it.
https://wiki.voip.ms/article/FreePBX_(PJSIP)


(Kappclark) #4

Thank you for the suggestions … I reset the expiration time as suggested …I changed Expiration about an hour ago, and so far so good … will let you know what occurs … meanwhile will track down those logs …


(Kappclark) #5

FWIW - I wanted to put the link to the voip.ms wiki about changing the registration from 3600 to 300, but as a new user, I am not permitted to put in links…

so - goto voip.ms website, and search for Registration_issue

Voip.ms advising to change expiration down from 3600 to 300

Curious when I wil get the right to post links in replies etc …


(Lorne Gaetz) #6

Just goosed your permissions, you should be able to add a link if you edit your post.


(Kappclark) #7

THX !

Figured I wld just post the txt from voip.ms wiki dealing with registrations —

  • Verify if your device has any field to set the “Register expires” , if you find something like this, you usually will see a default of 3600 (seconds), lower this value to 300 (5 mins). This tells our side that you are no longer registered and then failovers will kick in immediately.

  • Register Expires is the parameter that controls how often your client contacts the SIP server to remind it that the client is alive and confirming its current location (public IP address and listening SIP port). The SIP server is supposed to set this timer as part of the reply to each Register command. If the automated setting doesn’t work you need to set this parameter manually according to the provider’s instructions.

  • Use the IP address from the server instead of the domain name, example: Use 96.44.149.186 instead of losangeles.voip.ms. This item is recommended as diagnostic only, if this works for you, then it is probably a DNS issue affecting in your network, test using it for a couple of weeks and then change again to the domain name, it is not recommended to have the registration with the Ip all the time, VoIP.ms will redirect the domain to another IP in the case of a server issue, but this will not work for you if you are not using the domain.


(Kappclark) #8

FWIW - I have not had any issues since making the suggested changes for the expiration of registration …thx again to the community …
was thinking of going with a “pure asterisk” solution, but so far, free pbx is filling the bill, and running in a ProxMox VM to boot,


(Jared Busch) #9

Without some weird special need, this is a huge waste of time, and thus money.

You would have an unsupportable (by anyone else) snowflake system. That is never a good option.


(system) closed #10

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.