FreePBX System Admin Update stalled

The System Admin Update has stalled (persisting through restart). I’m following up on a past update that never completed. Current Version is 10.13.66-20, and it says that the 10.13.66-22 update is in progress:

2018-01-15 12:21:12: (10.13.66-22) Requesting updates
2018-01-15 12:21:13: (10.13.66-22) Processing update
2018-01-15 12:21:13: (10.13.66-22) Now running 10.13.66-21 script
2018-01-15 12:21:13: (10.13.66-21) Starting stage 1

And that’s all in the log. I’m guessing there is something to delete and retry the install via command line? But not sure what might be mangled and needs to be removed.
This is running on a Sangoma box with the Sangoma Distro

 /usr/sbin/sysadmin_update_system --unlock

Tried that:
[[email protected] ~]# /usr/sbin/sysadmin_update_system —unlock
Update already in progress![[email protected] ~]#

Have tried a couple times, and rebooted in between. Still no luck. Will probably need a trouble ticket.

You didn’t type it the way Lorne typed it.

So I just did it from a different machine and it worked- looks like something was on autoformat/correct and turned the double-hyphen into an emdash. Got that corrected and it looks better. Will kick off the update tonight.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.