Freepbx SNG7 - proper ugrade from 32bits version using conversion tool - would need a little help

I’ve upgraded my system from 10.13.66 to SNG7 using the following method:

10.13.66 32bit to 10.13.66 64bit using conversion tool
Upgraded 10.13.66 using
yum -y install

This seemed to work well, but once I was done configuring the trunks, I discovered that all my announcements had not transferred, and since my phone system has a time condition that will direct the call to an announcement if the customer is calling outside of business hours, my phone system failed to come up. Since the conversion tools brings everything, it would seem useful to brings announcements too.

I then realized that some modules from a previous era had followed from 10.13.66 32bit. - the one that struck me was the Digiums ones; I have a ISO install of SNG7 and confirmed that some modules that were present in my original 10.13.66 32bit were now appearing in my updated PBX.

Later, I noticed that the following:
| Your system is currently up to date! |
| Your PBX is up to date. |
| Also 4 Uninstalled modules. |

  • I checked what was “Not installed” and “sipstation” was one of them. Trying to install the module got me this screenshot:

I also noticed that Queue Pro want not installed and that was causing issues in the fail2ban log: something was looking for the presence of audio files to work with the queues, so I reinstalled Queue Pro and the messages in the log are no longer present (after renaming the log to get cleaner data) - but there are quite a bit of “error loading module” left in the log. I tried pasting the Fail2ban log here, but that made the post exceed the limit of 32000 characters.

So far, I’m having a blast with Freepbx, but unfortunately, I run into many bugs that may or may not have consequences… Right now, SIPSTATION really is the one that bugs me, as I’d like to get Sangoma phones for my team.

(additional info: I tried executing from CLI fwconsole ma downloadinstall sipstation

[root@FreepbxV3 ~]# fwconsole ma downloadinstall sipstation --force
No repos specified, using: [standard,extended] from last GUI settings

Downloading module ‘sipstation’
Processing sipstation
617497/617497 [============================] 100%
Finished downloading
Download completed in 7 seconds

In utility.functions.php line 207:

trying to set keyword [SS_API_URL] to [] on uninitialized setting::

ma [-f|–force] [-d|–debug] [–edge] [–color] [–skipchown] [-e|–autoenable] [–skipdisabled] [–snapshot SNAPSHOT] [–format FORMAT] [-R|–repo REPO] [-t|–tag TAG] [–onlystdout] [–willupdate] [–securityonly] [–sendemails] [–] []…

Thanks for those who will take the time to look at this post!

*** Update: I just reinstalled everything from scratch, used the conversion tool again to go from 32bit to 64bit. Right after the install, here’s what I got:
exit: 1
Whoops\Exception\ErrorException: Invalid argument supplied for foreach() in file /var/www/html/admin/modules/parking/ on line 16
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/parking/
  2. Whoops\Run->handleError() /var/www/html/admin/modules/parking/
  3. parking_check_extensions() /var/www/html/admin/libraries/usage_registry.functions.php:33
  4. framework_check_extension_usage() /var/www/html/admin/libraries/usage_registry.functions.php:420
  5. framework_list_extension_conflicts() /var/lib/asterisk/bin/retrieve_conf:789

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.