FreePBX showing as unkown

I’ve done something horrible. I restored the system configuration on a 2.10, but the one I restored ended up being from a 2.9 install instead of a 2.10 one. While trying to fix this, I’ve gone from bad to worse, I was getting a “retrieve_conf failed, config not applied” error, so I tried disabling all of my modules thinking one of them was causing this. I then deleted all the modules via ssh, since I thought I could just reinstall all of them. But now I am getting “Warning: Error retrieving updates from online repository(s) (). Online modules are not available” when trying to check online for modules. Now the main system status page only shows text, with no navigation bar across the top.

Now when I type status in the terminal it is showing FreePBX Version = UNKNOWN . and googling that showing nothing. There were a few about the asterisk version being unknown.

Any ideas on any of this?


I was floundering around, and I realized i might be able to upgrade to 2.10 again. I ran the install_amp script again, since I thought , what was the worst that could happen, and it seems to be all good now. The FreePBX version shows as 2.10, and the gui is loading correctly.