FreePBX returning number is not in service for all outgoing calls

Have an asterisk server set up that is handling phone calls from a number of sources. On a new Cisco IAD2400 setup, inbound calling to a phone on the IAD2400 works fine, but when you try to place an outbound call from the phone the asterisk returns that the number is not in service. It does this for any number you call from the phone.

Here is an attempt to call my cell phone from the IAD2400 (216.24.28.250). My cell phone number works fine, and calls from other SIP trunking clients out to the PSTN work fine through this server, but for some reason calls from the IAD all get that the number is not in service.

216-24-23-90*CLI> == Using UDPTL TOS bits 184 == Using UDPTL CoS mark 5 == Using SIP RTP TOS bits 184 == Using SIP RTP CoS mark 5 -- Executing [5023871095@from-sip-external:1] NoOp("SIP/216.24.23.90-000002ee", "Received incoming SIP connection from unknown peer to 5023871095") in new stack -- Executing [5023871095@from-sip-external:2] Set("SIP/216.24.23.90-000002ee", "DID=5023871095") in new stack -- Executing [5023871095@from-sip-external:3] Goto("SIP/216.24.23.90-000002ee", "s,1") in new stack -- Goto (from-sip-external,s,1) -- Executing [s@from-sip-external:1] GotoIf("SIP/216.24.23.90-000002ee", "0?checklang:noanonymous") in new stack -- Goto (from-sip-external,s,5) -- Executing [s@from-sip-external:5] Set("SIP/216.24.23.90-000002ee", "TIMEOUT(absolute)=15") in new stack Channel will hangup at 2012-04-30 14:30:48.533 EDT. -- Executing [s@from-sip-external:6] Answer("SIP/216.24.23.90-000002ee", "") in new stack -- Executing [s@from-sip-external:7] Wait("SIP/216.24.23.90-000002ee", "2") in new stack -- Executing [s@from-sip-external:8] Playback("SIP/216.24.23.90-000002ee", "ss-noservice") in new stack -- <SIP/216.24.23.90-000002ee> Playing 'ss-noservice.ulaw' (language 'en') 216-24-23-90*CLI>

We are not requiring authentication on connections because we are limiting who can connect by ip number, and in some other ways. But I suppose in the context of the freepbx box these are guest users. We don’t have this problem with most ATA’s we have configured to talk through the asterisk server, but I am guessing that they are telling something to the asterisk server that allows it to override the guest status for them. I just need to figure out what that is and figure out how to tell the asterisk box to do that.

I am doing what looks to be the very same thing…I had this working fluently last week in a test set up and now, am struggling to get the live set up working…but we are using pure sip from different servers on the same network. Your CLI looks identical to mine righen now!

When I get it working again, I will post it! Please do the same if you have it working first…

Notice the dialed number is a DID? That is because either you have your trunk for the gateway in the wrong context or your trunk is wrong altogether, you have anonymous SIP turned on and the call is entering that way.