FreePBX Panel flashing Red and Green

Once I installed Flash Player (from FOP panel stopped working. After uninstalling and re-installing from Adobe archive the FOP panel started working once again. After looking at the network traffic from the and case I noticed the following:

With the player, the FOP panel would initiate two connections to the FOP server at port 4445. In the case of the player, only the first connection would be done and it would be identical as the first connection with the case.

I have reported this to Adobe but I don’t have a support agreement with them so if anyone does they may have more pull then me.

I have created bug #2782 to track this issue.

I’m not tryig to deflect it but the author of the FOP is at have you taken a look over there to see if he knows about it and/or posted a fix already. If so it would be easier to pull his supported fix back then attempt to get somebody here to look into it and fix it.

It looks like he rolled out a new version on March 31st…

Thanks for the pointer. I had no clue. I just created change #15 on the asternic bug system (using Trac)

Check this post in asternic:

Yes, replacing the the
in /var/www/html/panel
with the one from here > Download
op_panel-snapshot.tar.gz 2008-04-10-16:45:04
solved the problem for me.

Thank you!

P.S. But this new fix breaks working with earlier Java version
Java Version 1.5.0 (9/8/06)


If I overwrite with the latest snapshot release of op_panel, all extensions flash red and green regardless of the version of Flash I’m running.

I’m running FreePBX on Ubuntu Linux 7.10 with Asterisk 1.4.19 and FreePBX 2.4.0.


This mismatch release of the and the resulting failure to access the panel is an ongoing problem. When I tried to use the svn version of the it then through some errors due to the config file in FreePbx being coded to use amportal conf.

Will there be an update to FreePBX to squash this bug anytime soon?

We use Debian & Ubuntu
for some users FOP worked. their plugin version is r48 .
the ones which did not work had version r124

aptitude purge flashplugin-nonfree

cp r48 version to each r124 user:

cp /home/rob/.mozilla/plugins/ /home/~tasha/.mozilla/plugins/
chown tasha ~tasha/.mozilla/plugins/

Of course you need a copy of version r48 around… Email me if you want a copy of the backup you gave me to store for you :wink:

Thanks for explaining that, I have just finished following your instructions and now i’m getting a client server version mismatch

any ideas?

Thanks again for your time.

If you replaced both and operator_panel.swf, then the problem is because your browser is using the old (cached) .swf . You will have to remove temporary internet files or empty your browser’s cache.

If you did not replace operator_panel.swf, then do so and them empty the cache.

Best regards,

Thanks for that, I just flushed my cache and all is working nicely. Thanks again for your time and effort.


For those who might still have an issue after following the instructions above… I found that the line added to the op_server.cfg must be placed under the [general] heading and not at the top of the file. After I made that change it worked as stated.

Hi all,
I followed all the steps and I had successfully removed my problem of getting all the extensions flashing red/green.
I put the new operator_panel.swf and from version .29

I put at the top of op_server.cfg right below [general]

Then remove temporary internet files and run amportal restart

Now, I’m having all in permanent green, never change the status of extensions, trunks or conferences

I’m having FreePbx version

Can someone help me please.


The latest snapshot fixes the policy constraints that are now part of the latest flash player. If you update it will work. The problem is that FreePBX uses a patched version to read configuration directives from amportal.conf.

Anyways, I have also added a configuration directive in op_server.cfg to read the config parameters from that file directly, so you can replace on a freepbx install and it will work (instead of trying to connect to UNUSED server with UNUSED manager user, etc…

That setting is:


And it should be written at the top of op_server.cfg

My situation is a little more complex. I use trixbox CE which bundles FreePBX which bundles asternic. So I have no idea HOW to get your fix. I am sure that my situation is similar to a lot of people. Can you explain in some details which files should be acquired from where and where they should be and what changes need to be done to what existing files to get this fix? Thanks a lot. Once I have this info here, I will submit it to FreePBX and trixbox for inclusion. Thanks.

Without details I did the following:

got subversion 28 from asternic and extracted and copied to my trixbox. I added the line use_amportal_conf=1 in general section in op_server.cfg on trixbox and restarted and the FOP is still flashing red and green. I await further instructions as I am sure more poeple are awaiting too.

From asternic I tried with the latest snapshot and with revision 28 and neither of them worked.

Refering to asternic post…

That worked for me. However, adding the line to the existing .cfg file did not fix the problem. I had to replace the .cfg from the svn in addition to the .pl file. Now it is whistling fine.

I will try to explain a little. Red/Green flashing means that the flash movie is unable to contact FOP proxy server ( That communication is done via a flash feature: xmlsockets. The default port for that connection is tcp/4445.

So, if you have a firewall, or the proxy is not running, or some wacky network setup, you might get the flashing red and green problem. This problem is not caused by the software itself but the network topology or some external issue. So the instructions that I will give won’t fix that issue. This applies only at the problem caused by the use of the LATEST flash player.

Now: the last flash player enforces a policy that afects xmlsockets. Now flash is not going to connect to anywhere unless the site that accepts the connections serves some special policy file.

That is the problem that I fixed in the latest FOP snapshot… it is not version 0.28, is the latest snapshot, for what I am going to release 0.29 tomorrow. The snapshot is also available for download, but with no version number, it will be always the latest version ( it is available in )

You can browse the source or get individual files from here:

The fix is done in, but you also have some version control between the .swf movie and the proxy server. So the proper way to update a freepbx install would be to download the latest snapshot tarball from the download tab in and replace both and operator_panel.swf.

Only those two files. You do not want to overwrite any .cfg file or anything else.

After that, you will have to add ONE parameter in op_server.cfg


That way it will read the config directives from freepbx config files instead of the op_server.cfg file that you have just modified.

Then restart FOP and it should work fine. (killall

The and operator_panel.swf files worked and panel is no longer showing red and green continuous flash.

What has happened is now 5 of my extensions are showing yellow and one is showing a black with DND set.