Freepbx on Raspberry Pi for 15 extensions and 5 SIP trunks

Hi.
I’d like to develop a Freepbx server based on Raspberry Pi.
The server must manage about 15 Exensions with no more than 5 SIP/Voip Trunks.
Is this an achievable project in an reliable way?
If the answer is yes, wich is the minimum Raspberry Pi hardware configuration requested?
Thanks in advance to all.

Hi!

I would say yes, I believe it would be powerful enough…

No…

You cannot put Raspberry Pi in the same sentence as reliable without preceding it with not.

Those SD cards it uses for storage are known to easily corrupt when used that way…

The last thing you want to do if you need to call 911/112 is to have to replace the SD card with an uncorrupted one…

Have a nice day!

Nick

I guess I should add, so that it doesn’t appear like I display fanboyism or anti-fanboyism, that I have 3 Raspberry PIs…

A 1, a 2 and a 0…

I would not use any of them for this and I did have SD cards corrupt…

Have a nice day!

Nick

I have several Raspberries as well (one running NetBSD as a 3D Printer Server), but I don’t think they’re the right platform for this application - too much drive thrashing and it’s a critical asset for most places.

The price it right, but not the platform.

tried freepbx on many arm devices, the CPU of raspberry pi 3 is powerful enough to run 5 sip trunks/15 extension.

However, SD as system disk is a problem as someone said, I had encountered SD failure, but I did image backup before, so very easy to recover system to another SD card.

Although PC is No 1 choice as pbx server, but arm-device is the trend to replace PC as light pbx server, so worth to have a try.

As mentioned above, the biggest weakness is the SD card volatility. I’ve owned several and used RasPBX without any SD card issues, but it is mentioned enough on the forums that I believe it is widespread.

A couple of ways I’ve observed others work around the SD card limitation were:

  • For systems that are pretty static, keep a clone of the working SD card. If it corrupts, just swap it out.
  • For RPi3s and above, set the PI to boot from a USB sata drive. Something to keep in mind is (I believe) the USB shares bus with the network port.

All that said you can find some pretty cheap refurbished Intel boxes that might be less hassle in the long run.

In my day job, we use SD Cards on some communication servers. We get cards that are “high rewrite” ($100 a pop) cards and have to replace them after about a year of use.

We tried consumer-class cards in our “high IO server”, and they lasted about a week. The worst lasted about three days, the best about two weeks.

I use that experience as my benchmark - it’s not an indictment of the Pi, it’s a problem inherent in the SD-Card media.

There are some pros and cons of Raspberries, yes the sd card doesn’t like being written to, yes you can set a otp bit to boot from usb , that usb could be a thumdrive, an ssd or a mechanical hdd, if you go the USB route

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=211912#p1321000

will ultimately relieve you of the need for an empty sd if using USB booting or sucking up CPU cycles.

Reasonably, you can expect a huge reliabilty performance using relatively cheap thumb-drives like Samsung or Sandisk over expensive SD cards. but if you end up with a 50 dollar pi relying on a 200 dollar ssd over usb you proibably under or over thought something. There are many alternatives to a raspberry, personally a Z8350 running an Intel 64 bit Atom processor is my preference it uses emmc memory (SD on steroids, never yet seen a failure)

https://www.lattepanda.com/

even got a built in arduino for geeks, less than 100 bucks and it can load a regular distro iso. Cheaper than a NUC faster than a Raspberry

2 Likes

Lattepanda seems a little expensive, perhaps someone can try orange pi pc plus with 8GB emmc, only $28.46 including shipping

Tried freepbx 14 on both orange pi pc and RPi3, no significant difference when running.

Another option is banana pi m2 ultra, which has 8GB EMMC and sata port

@dicko What size FreePBX do you think you could run off of the 4G/64GB Panda? I’ve been looking at these and the UpBoards as potential options, but it hasn’t been clear on what to expect capacity-wise.

Rule of thumb? I would say should be good for a couple hundred extensions or more. and the cpu for plenty of trans-coding. Asterisk is remarkably low overhead, 1G of ram is more than enough, figure about 4 or 5 G for the ‘system’ you are left with the rest for recordings.
I have vultr instances of 1G 1CPU that handily do 100 extensions with heavy duty faxing no problem.

2 Likes

Do you have a rough in on how many concurrent calls you’d feel comfortable seeing on that box?

I suggest you look at

http://sipp.sourceforge.net

You can benchmark using different codecs , if you are postprocessing a lot ( for example ghost script for faxes or sox for mp3) use ‘nice’ on any scripts called by your system

1 Like

Hi…there have been significant enhancemets made to a number of the utility scripts located in /root which should be replaced with those from this package. This can be accomplished by placing install.tar.gz in your /root directory and running.

@dicko, does the LattePanda run a standard distro? Taking a stab at one, and it seems to lose the display. I can see the mouse, and can move it but other than that the monitor is blank

The latte pandas I have used are Celeron N3350 Processor’s with an arduino strapped on their back, the bios supporst android or windows(uefi) booting , you can install any linux that you want to, Including the FreePBX Sangoma distro . if the monitor is blank , depending on the distro add nomodeset to the grub arguments

Thank you for the reply. Picked up one of the 2gb/32gb models. I should have said the monitor does come up, the unit boots from a USB and allows me to choose the options to install the distro. It scrolls through a bunch of the loading and driver script, then when it goes to change over to the distro GUI where you enter your root password, I think thats where the monitor goes black, with just the mouse pointer.

Pick the automatic or vnc install mode if the screen isn’t working properly.

Automatic got me past that point, now it looks like I have an issue with storage. Says there is 29.12gb free, but when I try one of the options to use the free storage, or replace existing partitions

Menu comes up and says requested boot drive does not exist, then I can select the drive (29gb) > replace existing linux system > choices are standard partition, btrfs, lvm and lvm thin - none of the choices seem to make a difference and fail with message not enough storage space

I’ve tried different variations of using free space, new partitions, then standard partitions, lvm and the others. All seem to result in not enough storage, although it says there is 29gb free