FreePBX on Linode

I’m trying to install FreePBX 13 iso on Linode basic server. When downloading it and choosing a Direct Disk Boot, I get an error that it couldn’t boot while there is no MBR on disk. I wasted a couple of hours without any hope. Just want to know if anyone did install the iso on Linode, isn’t it simpler if I install FreePBX on a centos distribution (although I’ve read on wiki that commercial modules won’t work in this case).
Please share your experiences about Linode and how you achieved it.

1 Like

I create a VM on my local computer and transfer it to Linode using this guide:

When you get to the part about setting the IP address after the transfer is done, don’t follow the guide for this portion… the recursive find and replace never worked for me. Instead, I just edited the eth0 file manually and updated the IP address and it worked like a charm.

Thanks Kenny, gonna give it a try

I recently installed FreePBX to Linode using the direct boot method. It has been long enough that I cannot recall the exact details, but in reviewing the download options, I am inclined to say that you would need to use the USB image rather than the ISO, as it does not appear that the ISO supported hybrid boot until the current release candidate.

I use Vultr and can highly recommend it. I am not an affiliate and don’t get any commission for this post but it’s a great service I believe they have the same pricing as Linode now but without the above issues. You can install FreePBX directly from a custom ISO.

Thanks, I’ll give it a try. For the time being as I couldn’t wait for more, I have to install manually. I’d try USB one shortly.

I confirm that USB ISO installed on Linode basic server without a major problem. Just to mention that you need a boot partition large enough for the Sangoma OS. I chose 15 GB.

1 Like

Linode has a guide to installing custom distributions.

One of the steps is downloading the distribution to a Linode installer disk, using wget.
This step fails with a certificate error:
ERROR: The certificate of '' is not trusted.

Any suggestions?


Excellent suggestion. I wonder why the site uses https in the first place.
I also discovered:
wget --no-check-certificate ...
‘curl -k …’