FreePBX on Azure VM

I am new to FreePBX and Linux. I tried to install this on an Azure virtual centos machine but have a lot of errors. Could this be because I can not run anything as true root?

Any help is appreciated

Thanks
JOsh

No mind readers here, what exactly are your errors?

1 Like

I guess I was trying to see if anyone was familiar with running it in a cloud environment with no root access. Asterisk doesn’t seem to run, I was able to start it by executing sudo -s asterisk -r
it was up but the FreePBX gui is inaccesible, I get an apache error

Still no mind readers here, if you have errors post them.

FreePBX works fine in many virtual environments, I myself use it all the time in a Linux KVM, but probably not many here would go the m$soft way.

Just because something can be done doesn’t make it worthwhile.

FreePBX doesn’t actually run as root, nor does Asterisk. It runs as asteriskuser. If you can create users that have full execute permissions that would be a start.

Azure is cheap and i heard a lot of good thins about their CentOS image.

[[email protected] ~]$ asterisk -r
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

Now when i run sudo -s asterisk -r

[[email protected] ~]$ sudo -s asterisk -r
[sudo] password for azureuser:
Asterisk 1.8.21.0, Copyright © 1999 - 2012 Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 1.8.21.0 currently running on techplus (pid = 54658)
Verbosity is at least 3
– Remote UNIX connection
– Remote UNIX connection disconnected
techplus*CLI>

So I am assuming asterisk is fine?

When I go to the URL for my freepbx techplus.cloudapp.net I get an apache test page

when I try to load
techplus.cloudapp.net/admin.config.php i get Not Found

The requested URL /admin/config.php was not found on this server.

Apache/2.2.15 (CentOS) Server at techplus.cloudapp.net Port 80

To identify what user is running the process:-

ps -auxf |grep -E “asterisk|httpd”

to identify who you are

whois

identify group membership with

id (user)

then you could add relevant lines to /etc/sudoers, to fix your bash access. the files in /var/www/html/admin/ need to be readable by your httpd user.