FreePBX Not Picking Up DTMF Tones From VoIP Phones

Hello all,

I have the newest version of the FreePBX distro ( that can be downloaded from this site that runs on CentOS.

I have a phone that is directly connected to the same network as the PBX. Phone is a D-Link DPH-125MS phone.

When I call into the IVR or call into voicemail, any buttons I push on the phone go through without a problem. So if I go to the IVR and want to press option 4, I’ll hit 4 on the phone and the IVR then goes to that menu. If I push the message button on the phone, FreePBX says “Password” and I’ll enter the password - then I can access my voicemails.

So FreePBX picks up on all DTMF tones from the phone on the same network without a problem.

However, I have another individual that uses my PBX and they have the same exact phone as me. He is connected through the Internet. NAT settings are all set properly and he is able to call my extension or dial out anywhere without a problem.

But, if he calls into the IVR or hits his Message button, FreePBX does NOT pick up on them. He can call the IVR and hit option 4, but the IVR continues on like nothing was received. He can call into voicemail and put in his password, but it is not accepted.

The extension settings in FreePBX are setup exactly the same - with DTMF set as RFC 2833.

The phones allow you to set The DTMF method as Out Band, In Band, or SIP INFO. I have tried changing the settings in FreePBX - changed to Auto - no difference. Changed to In Band Audio and changed the phone to In Band - no difference. Changed the phone to SIP INFO and FreePBX to SIP INFO - no difference. FreePBX simply seems to ignore the DTMF signals being sent.

Does anyone else have such a problem, and is there any recommendations? Because the call is simply being placed between a phone on the FreePBX system and FreePBX itself, it wouldn’t have anything to do with any outside provider.

Thank you!

I suspect that his phone is not configured exactly the same as yours, with respect to sending DTMF.

You should leave FreePBX at RFC2833, and try different settings on the remote phone. Also, make sure both phones have the latest firmware (or at least the same firmware).

If you still can’t get anywhere, I’d try using a softphone remotely and locally to rule out any NAT/Firewall issues.

I’ve confirmed the phones are configured exactly the same. Both phones have a web-based configuration utility - so I opened up both simultaneously and went through the settings.

Everything is configured properly - although the other phone is in the Eastern Time Zone. I did set it to Central Time (same as mine) to see if it made any difference and it does not.

Firmware and everything is identical as well.

Will try the softphone idea. He does have a softphone but never really used it.

OK - so he just setup X-Lite on his computer and the IVR and voicemail does not recognize DTMF tones either. He also tried to call another outside 800-number and it wouldn’t recognize DTMF tones.

I connected a softphone called Twinkle that runs on Linux from another Internet provider and DTMF tones work just fine.

Have you tried X-lite locally? What result?

Have you tried X-lite with a VOIP provider from both locations as well?

I am having the same issue. Did you ever get this resolved?

X-Lite also does not recognize my dtmf tones.

I had a similar experience that ended up being an intermittent issue related to the remote users router. He had a Belkin router that apparently did not play well with SIP. Probably not your issue, but may spark an idea. Hope you find your solution.